Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I installed ubuntu 11.10, 64 bits I didn't have to install any kind of graphics drivers and all 3d efects were working fine. Now, it seems to be that graphics drivers are uninstalled. I can't use unity 3d or any compiz effects.

I have a laptop Sony Vaio VGN-NW330F, my graphics drivers are intel mobile 4 series chipset integrated graphic controller.

share|improve this question
this worked also for me on ubuntu 14.04 LTS – user272123 Apr 21 '14 at 19:27
user272123 is correct but the unity --reset option no longer works. Use dconf reset -f /org/compiz/ instead, then run setsid unity. – Terry Oct 13 '14 at 16:27
up vote 17 down vote accepted

The solution is here:

sudo apt-get purge nvidia-*
sudo apt-get install --reinstall xserver-xorg-video-intel libgl1-mesa-glx libgl1-mesa-dri xserver-xorg-core
sudo dpkg-reconfigure xserver-xorg
sudo update-alternatives --remove gl_conf /usr/lib/nvidia-current/

After that I did unity --reset and all is working fine again. Thanks to Micro :)

share|improve this answer
This also seemed to work for re-installation of the drivers for 14.04 LTS. – JRSofty Apr 19 '14 at 9:23
this works for me after I upgrade from 13.10 to 14.04. My video driver was recognized wrongly as "Gallium 0.4", so the display was poor, no sound, no hotkey (i.e. Fn+..), no wireless etc. After I did the solution above, restarted, everything goes back to track as it was in 13.10. In "System Settings" --> "Details", it shows again "Intel Sandybridge Mobile". Many thanks! – ycheng Aug 17 '14 at 12:48
Unity reset is deprecated, – Kalamalka Kid Mar 3 at 20:35

in general you can run lshw -c video from a terminal to get all the basic info about your VGA, without knowing anything you can also run lspci -n and paste the output at this page to get the name of the required module under a general Debian-like distribution like Ubuntu.

Keep in mind that some modules require additional configuration but usually Ubuntu automate all the tasks for you, but it's always a good thing to google a bit more about the module you are about to install under your system.

Also check di utility "additional driver" in your control panel for further tips.

PS for the same hardware several modules can be available, the site that i suggest usually display the one that are already available in the official repository, for example for an ATI VGA the site display the module radeon but you can also use the proprietary driver that you can download from the AMD website.

share|improve this answer
My driver seems to be i915, how do I install it? – Aikanáro Nov 20 '11 at 3:58
probably your problem is due to a kind of bug, try reading this… – Micro Nov 20 '11 at 4:06
to answer your first question the appropriate package for your driver is xserver-xorg-video-intel and you can find it in the repository. – Micro Nov 20 '11 at 4:08
I don't think that's my problem. All the system, desktop, effects were working fine with the default drivers. Anyway, that's not the problem, I reinstall the driver and all stay the same. I don't know whay else I can try. I tried reset unity, remove all config file from my home directory, restore compiz to default settings, reinstall compiz and unity, but nothings works. – Aikanáro Nov 20 '11 at 4:16
run jockey-gtk and report what happens, the VGA and the driver from Intel are well known as a bad solution for your graphics, do not expect too much. – Micro Nov 20 '11 at 4:22

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.