Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been looking at different tutorials about rsync about some specific situation I have.

I have a home server with all my pics, this server is my backup, my PC is the one that receives the new pics and until now i had been manually copying and pasting new photos from the PC to the server.

I was trying to setup rsync to do this automatically and in principle, it does without problem.

Now the issue; when I fire up rsync it start copying all the files, even the ones were already in the destination (this is because it is the 1st sync).

so my question is: Is it possible for rsync to verify that a file is the same (name/size/bin) so it will skip the copy on the 1st sync?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

You mean it starts copying everything again because even though they're already there, they have different timestamps because you copied them over yourself?

The --size-only flag, or --checksum, might be what you need to stop it doing that, but the first time you run rsync without that flag it will revert back to this behaviour.

You can probably fairly safely run it all the time with --checksum though, I think, so it might not be an issue.

share|improve this answer

I once had an issue where rsync would always copy all the files every time. I then learned that it has happening because I was syncing between windows and linux and the former has lower timestamp precision.

I solved my problem adding the --modify-window=1 parameter to the rsync command which compares mod-times with reduced accuracy.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.