Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just got a new Acer Aspire S3 Laptop, and I've installed Ubuntu on it. Here is some problems:

1. Bluetooth (AR3012) can't find any devices. rfkill shows that everything is fine, but I still can't connect to any device. (Maybe it was turned off in stock windows?)

2. Can't change screen brightness (I've tried Timex's solution with new 3.2-rc kernel and some grub options, touchpad works fine,but I still can`t use Fn+Right/Left)

3. 720p video in all players(VLC, mplayer and totem) works wrong. I found some similar problems on intel video chips with vblank sync or something like that. Video plays as it should, but i always see a line which appears on action scenes (looks like some parts of a screen updates faster)

Maybe there are some solutions from similar laptops that I can find?

PS I've tried ubuntu 11.04 with old kernel and linux mint 12-rc with 3.2-rc2 kernel.

share|improve this question
add comment

2 Answers 2

up vote 1 down vote accepted

1) Bluetooth works with kernel patch 2) Brightness needs lines in /etc/default/grub

    pcie_aspm=force
GRUB_CMDLINE_LINUX="quiet splash pcie_aspm=force i915.i915_enable_rc6=1 acpi_osi=Linux acpi_backlight=vendor"

3) This problem calls "Screen Tearing". New intel video drivers will probably fix this.

Very similar laptop is Asus Zenbook UX21/31... It uses similar wifi/bt module...

share|improve this answer
    
If this is the answer to your question you should accept it so others know it works. It also helps your reputation here. –  Tom Brossman Mar 21 '12 at 9:25
add comment

I tried to summarize the problems of the Acer Aspire S3 on Linux on this page.

http://www.linlap.com/wiki/acer+aspire+s3

Going on the 3.2 rc2 kernel way has proven wrong for me. Although the track-pad was recognized, I lost right click, and the possibility to click a zone selection. I went back to the stock Ubuntu kernel.

Hope this helps.

share|improve this answer
    
I`ve just found bluetooth solution. I`ve added my device id to btusb.c and ath3k.c and compiled kernel. Solution seems to be similar to Asus UX31. I don`t know how to make and post patch. $ diff btusb.c btusb.c.old 122,123d121 < { USB_DEVICE(0x13d3, 0x3375), .driver_info = BTUSB_ATH3012 }, < { USB_DEVICE(0x04ca, 0x3004), .driver_info = BTUSB_ATH3012 }, $ diff ath3k.c ath3k.c.old 73,74d72 < { USB_DEVICE(0x13d3, 0x3375) }, < { USB_DEVICE(0x04ca, 0x3004) }, 91,92d88 < { USB_DEVICE(0x13d3, 0x3375), .driver_info = BTUSB_ATH3012 }, < { USB_DEVICE(0x04ca, 0x3004), .driver_info = BTUSB_ATH3012 }, –  xcariba Dec 3 '11 at 20:12
    
@xcariba Can you give a more detailed explanation as to how you did this? I'm having the same issue with bluetooth and Kubuntu 13.04. –  Michael D May 16 '13 at 8:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.