Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

this is an issue I have googled a lot and I have tried a lot of fixes, but non of them really worked.

At some point (I can't remember when/how) my Update system sort of broke, and since then it is always complaining about "Not all updates can be installed, run a Partial Upgrade".

enter image description here

If I click on Partial Upgrade, I get the following result

enter image description here

But running apt-get install -f does not fix anything, and at the end I always get the following message

enter image description here

Funny thing is that my apt-get system works perfect on Console. I can update my system through apt-get update, apt-get upgrade etc..

So.. how can I fix the graphic interface? I understand that my apt-get system is not broken, but somehow its GUI it is.

Any thoughts about it?


P.D: I have already tried sudo dpkg --configure -a and sudo apt-get autoremove

Edit: This is the output I get after sudo apt-get update && sudo apt-get upgrade

> dan@dan ~ $ sudo apt-get update && sudo apt-get upgrade Ign
> oneiric InRelease Ign
> oneiric-security InRelease Ign
> oneiric InRelease Ign
> oneiric-updates InRelease Ign
> oneiric-backports InRelease Hit
> oneiric Release.gpg Hit
> oneiric-security Release.gpg Hit
> oneiric Release Hit
> oneiric Release.gpg Hit
> oneiric-updates Release.gpg Hit
> oneiric-security Release Hit
> oneiric-backports Release.gpg         Hit
> oneiric Release                       Hit
> oneiric/partner i386 Packages         Ign
> oneiric/partner TranslationIndex         
> Hit oneiric-updates Release             
> Hit oneiric-backports Release           
> Hit oneiric-security/main Sources          
> Hit oneiric/main Sources                 
> Hit oneiric/restricted Sources          
> Hit oneiric/universe Sources            
> Hit oneiric/multiverse Sources          
> Hit oneiric/main i386 Packages          
> Hit oneiric/restricted i386 Packages    
> Hit oneiric-security/restricted Sources   
> Hit oneiric-security/universe Sources     
> Hit oneiric-security/multiverse Sources   
> Hit oneiric-security/main i386 Packages   
> Hit oneiric-security/restricted i386
> Packages Hit oneiric/universe i386
> Packages       Hit oneiric/multiverse
> i386 Packages     Hit oneiric/main
> TranslationIndex        Hit
> oneiric/multiverse TranslationIndex  Hit
> oneiric/restricted TranslationIndex Hit
> oneiric/universe TranslationIndex Hit
> oneiric-updates/main Sources         Hit
> oneiric-updates/restricted Sources   Hit
> oneiric-security/universe i386 Packages Hit
> oneiric-security/multiverse i386 Packages Hit
> oneiric-security/main TranslationIndex Hit
> oneiric-security/multiverse
> TranslationIndex Hit
> oneiric-security/restricted TranslationIndex Hit
> oneiric-updates/universe Sources     Hit
> oneiric-updates/multiverse Sources   Hit
> oneiric-updates/main i386 Packages Hit
> oneiric-updates/restricted i386 Packages
> Hit oneiric-security/universe
> TranslationIndex Hit
> oneiric-updates/universe i386 Packages Hit
> oneiric-updates/multiverse i386 Packages
> Hit oneiric-updates/main TranslationIndex
> Hit oneiric-updates/multiverse
> TranslationIndex Hit
> oneiric-updates/restricted TranslationIndex Hit
> oneiric-updates/universe TranslationIndex
> Hit oneiric-security/main Translation-en  
> Hit oneiric-security/multiverse
> Translation-en Hit oneiric-backports/main
> Sources       Hit
> oneiric-backports/restricted Sources Hit
> oneiric-backports/universe Sources   Hit
> oneiric-backports/multiverse Sources Hit
> oneiric-backports/main i386 Packages Hit
> oneiric-backports/restricted i386 Packages Hit
> oneiric-backports/universe i386 Packages
> Hit oneiric-backports/multiverse i386
> Packages Hit oneiric-backports/main
> TranslationIndex Hit
> oneiric-security/restricted Translation-en Hit
> oneiric-backports/multiverse
> TranslationIndex Hit
> oneiric-backports/restricted TranslationIndex Hit
> oneiric-backports/universe
> TranslationIndex Hit oneiric/main
> Translation-en_GB       Hit oneiric/main
> Translation-en          Hit
> oneiric/multiverse Translation-en_GB Hit
> oneiric-security/universe Translation-en Hit
> oneiric/multiverse Translation-en    Hit
> oneiric/restricted Translation-en_GB Hit
> oneiric/restricted Translation-en Hit
> oneiric/universe Translation-en_GB Ign
> oneiric/partner Translation-en_GB Hit
> oneiric/universe Translation-en Hit
> oneiric-updates/main Translation-en Hit
> oneiric-updates/multiverse Translation-en
> Hit oneiric-updates/restricted
> Translation-en Hit
> oneiric-updates/universe Translation-en Hit
> oneiric-backports/main Translation-en Ign
> oneiric/partner Translation-en Hit
> oneiric-backports/multiverse
> Translation-en Hit
> oneiric-backports/restricted Translation-en Hit
> oneiric-backports/universe Translation-en
> Reading package lists... Done Reading package lists... Done Building
> dependency tree        Reading state information... Done 0 upgraded, 0
> newly installed, 0 to remove and 0 not upgraded. dan@dan ~ $
share|improve this question

1 Answer 1

Review your software sources, and remove any unused or outdated repositories.

Try one (or more) of these:

(remove unmet dependencies)
sudo apt-get -f install

(remove .deb archives from packages no longer installed)
sudo apt-get autoclean

(clear files from Aptitude cache: /var/cache/apt/archives )
sudo apt-get clean

Post the output of an update & upgrade:

sudo apt-get update && sudo apt-get upgrade


Your active sources should (most likely) not include the 'backport' elements:

This is from my setup: (edited to 'GB', instead 'NZ')

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb maverick-backports main restricted universe multiverse
# deb-src maverick-backports main restricted universe multiverse

Whereas your 'sources' appear to be: (or equiv.)

deb oneiric-backports main restricted universe multiverse

These should also NOT say 'oneiric-backports' !?

share|improve this answer
I did all you said, and I have updated the question with the output. As you can see, everything looks fine in console, but then GUI complains about "Partial upgrade". –  Dan Nov 20 '11 at 10:55
Do you know why you have so many sources (including backports) included? Unless these are needed, this may be at least part of cause .. –  david6 Nov 20 '11 at 11:16
Can you point me to a "default" sources for oneiric? I cannot find them. Thanks –  Dan Nov 20 '11 at 11:26
Default /etc/apt/sources.list for Ubuntu 11.10 GB/UK –  david6 Nov 20 '11 at 11:31
Should be no reason to autoclean and clean - apt-get clean will remove them all - including those that autoclean would have. –  23 93 26 35 19 57 3 89 Apr 6 '12 at 6:16

protected by Community May 2 '12 at 18:00

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.