Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Running banshee on Ubuntu 11.10 with gnome 3.

Music stops playing when the screen turns off (Like powersave mode / when the screensaver turns on) when it gets to the end of the currently playing song. If I come back to the computer it will start playing again.

I tried making the computer not lock in case that was the cause but it still stops playing when the screen saver comes on.

Besides making the screen stay on is there another solution?

Thanks

share|improve this question
    
Are you using Banshee or what to play your media? –  budwiser Nov 20 '11 at 1:44
    
Yes I am using banshee. I wrote that in my question. "Running banshee..." –  cohen Nov 21 '11 at 10:15
    
Does the music actually stop, or is it just muted? –  michaelms Jan 20 '12 at 18:23
add comment

3 Answers 3

Are you on a laptop computer or on a desktop one? If you are using a desktop one, i remember having the same problem when i used the built-in speakers of my display... Every time the display would go on energy-saving mode (actually standby mode), the speakers would come off as well. As soon as I used separate speakers, the problem disappeared.

Hope this helps.

share|improve this answer
add comment

I was having this same problem in Linux Mint Maya (based on Ubuntu 12.04): Banshee is playing, monitor powers off after some amount of idle time (though screen does not lock), Banshee finishes playing track and then stops. When I move the mouse and the monitor comes back on, Banshee starts up again.

I wondered why Banshee was going to the end of the song and THEN stopping. So I figured maybe it had to do with new-track notifications. Sure enough, I disabled Banshee's "Notification Area Icon" extension (In Edit->Preferences->Extensions tab) and now Banshee keeps on playing just fine, new tracks and all, after the monitor goes off. I don't get pop-up notifications between songs anymore, but that's a small price to pay on my end.

I'm going to go mention this in a related bug report; if it works for you, consider saying so there so that we might help the developers find the real source of this issue.

share|improve this answer
add comment

I believe that this has something to do with your xscreensaver. I had the same problem and solved it by completely deactivating it (in xscreensaver-demo). You can still let your screen get turned off after some time of inactivity by using gnome-screensaver and controlling it through the control panel afaik. Banshee isn't affected by this.

Edit: it seems as if that wasn't fully it. I still seem to encounter this problem from time to time.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.