Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've got 11.10 on a desktop machine with two users. Both users have "Password" set to "Not asked on login" in Users Settings. At startup, either user can log in without a password. But once both users are logged in, it takes a password to switch between users.

In previous Ubuntus, you could override this by setting /desktop/gnome/lockdown/disable_lock_screen to True in gconf-editor. That is ignored in the Gnome 3 / Unity era.

Does anyone know a way to disable the password prompt when switching between users in Oneiric?

share|improve this question

2 Answers 2

Run this command:

sudo visudo

Then, at the end add this line:

user   ALL=(ALL) NOPASSWD: /bin/su

This will disable the password check for the "su" command for the specified user.

cheers

share|improve this answer
    
This doesn't work for me. Still password prompt. However, if you choose "Switch User Account" instead, and then select another user from the startup screen, then you gen logged in without password prompt. What is my problem? –  Dziamid Apr 11 '12 at 20:29

Only this worked out for me:

gsettings set org.gnome.desktop.lockdown disable-lock-screen 'true'

This disables screen lock on user switch and hibernation wakeup.

PS: gsettings has to be configured for every user seperately.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.