Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

I have a Traktor Audio 2 DJ USB sound card (the first version of what it's now called simply Traktor Audio 2)

The problem in settings it only sees one output, when there should be two (I need that for Mixxx etc.)

Also I want to be able set the sample rate to one of these: 44.1, 48, 88.2, 96 kHz or at least check which one is set.

Additionally if possible setting the latency would be an advantage.

Some info:

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDA ATI HDMI], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: TraktorAudio2 [Traktor Audio 2], device 0: Traktor Audio 2 [Traktor Audio 2]
  Subdevices: 1/2
  Subdevice #0: subdevice #0
  Subdevice #1: subdevice #1

$ cat /proc/asound/cards
0 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xfdcfc000 irq 45
1 [TraktorAudio2  ]: snd-usb-caiaq - Traktor Audio 2
                      Native Instruments Traktor Audio 2 (usb-0000:00:1d.7-8)
share|improve this question

marked as duplicate by Oli Jan 16 '14 at 10:23

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
For those of you looking for the answer for the newer version of the Audio 2 DJ (the Audio 2): askubuntu.com/q/214749/9781 – David Planella Nov 9 '12 at 10:48

Maybe this can help you: Audio2DJ, with Mixxx on Ubuntu Linux

In summary, you need to create an .asoundrc file in your home folder with the following contents. Then you should be able to select each one of the channels (e.g. djA, djB, djAB) in your audio software's preferences (e.g. Mixxx).

#-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
# Native Instruments :: Audio2DJ ALSA Configuration
# - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
#
#    device channels        ports
#    --------   ---             ---------
#    djA        2               12xx
#    djB        2               xx34
#
#    djAB       4               1234

#-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
# dj(a-d) :: Raw 1x1 Stereo Devices
# - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
pcm.djA { type plug; slave.pcm "hw:Audio2DJ,0,0"; }
pcm.djB { type plug; slave.pcm "hw:Audio2DJ,0,1"; }


# - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
# djAB :: Multi 2x2 Stereo Device (Ports 1-4, Channels A+B)
# - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
pcm.djAB {
        type multi

        # bind hardware devices
        slaves.a.pcm djA
        slaves.a.channels 2
        slaves.b.pcm djB
        slaves.b.channels 2

        # bind channels to virtual device
        bindings.0.slave a
        bindings.0.channel 0
        bindings.1.slave a
        bindings.1.channel 1
        bindings.2.slave b
        bindings.2.channel 0
        bindings.3.slave b
        bindings.3.channel 1
}
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.