Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've a Wacom Bamboo Create Pen Tablet (CTH-670) which is not detected by the system settings, ubuntu 11.10

uname -r 3.0.0-13-generic-pae

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 046d:c512 Logitech, Inc. LX-700 Cordless Desktop Receiver
Bus 002 Device 002: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 003 Device 003: ID 056a:00df Wacom Co., Ltd 
Bus 002 Device 004: ID 03f0:0601 Hewlett-Packard ScanJet 6300c
Bus 002 Device 005: ID 067b:2305 Prolific Technology, Inc. PL2305 Parallel Port
Bus 002 Device 006: ID 0409:0056 NEC Corp. 

lsmod | grep wacom

try to autogen driver input-wacom-0.11.1 from git, but fails with

configure: WARNING: kernel version 3.0.0-13-generic-pae not supported

Anyone has a solution ?


Continued with sucessful make in 2.6.36 folder and copied wacom.ko to kernel

$ sudo insmod /lib/modules/3.0.0-13-generic-pae/kernel/drivers/input/tablet/wacom.ko
csschsu@omega:~$ dmesg | tail

[  191.006084] usbcore: registered new interface driver wacom
[  191.006091] wacom: v1.52-input-wacom-0.1:USB Wacom tablet driver

Output of lsusb:

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 046d:c512 Logitech, Inc. LX-700 Cordless Desktop Receiver
Bus 002 Device 002: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 002 Device 003: ID 03f0:0601 Hewlett-Packard ScanJet 6300c
Bus 002 Device 004: ID 067b:2305 Prolific Technology, Inc. PL2305 Parallel Port
Bus 002 Device 005: ID 056a:00df Wacom Co., Ltd 
Bus 002 Device 006: ID 0409:0056 NEC Corp. 

looks fine ? But still empty system settings screen ( and wacom.ko is not loaded after reboot, been running depmod -a, and modules.dep is updated )

Tried to use wacom on a fresh installed 11.10 on another machine but same problem there.


Note from syslog when connecting wacom to USB ( indicate loading another module ?)

Nov 22 17:43:09 alfa kernel: [64305.585914] usb 2-1.6: new full speed USB device number 4 using ehci_hcd
Nov 22 17:43:09 alfa mtp-probe: checking bus 2, device 4: "/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.6"
Nov 22 17:43:09 alfa mtp-probe: bus: 2, device: 4 was not an MTP device

$ lsusb

Bus 002 Device 004: ID 056a:00df Wacom Co., Ltd 

is MTP the cause of missing detection, and if so what to do about it.

Wacom board is a Bamboo CTH-670 and it works ok on windows but I don't :-\

Removed libmtp-common and that clears the message in syslog but wacom table usb device is not detected and the wacom.ko kernel module is not loaded.

share|improve this question
    
"Works with Windows, but I don't"—bingo! –  Kazark Dec 29 '12 at 15:58

3 Answers 3

00df device isn't included in the list of supported devices in wacom_wac.c, check the the post:

Instructions in the post are a bit contradictory but I finally have the wacom tablet working after downloading wacom-bamboo.tar.gz and unzipping the contents into 2.6.36 in the latest gitcheckout of the input-wacom folder. Downloaded wacom-bamboo.tar.gz from

after build, move wacom.ko to the lib/modules/ folder.

wacom is now active, but a warning, there are more diffs between the wacom_wac.c code than just support for the usb device used. How to correctly merge the code changes is not obvious to me. Guess I'm up to new "happy" surprises.

share|improve this answer

I've used lekensteyn/wacom-tablet ppa repository

Natty 11.04

sudo add-apt-repository ppa:lekensteyn/wacom-tablet
sudo apt-get update
sudo apt-get install linux-headers-generic-pae
sudo apt-get install dkms wacom-dkms

Oneiric 11.10

sudo add-apt-repository ppa:lekensteyn/wacom-tablet
sudo apt-get update
sudo apt-get install dkms wacom-dkms
share|improve this answer

I too have Oneiric and the same tablet (00df). I report that I have found one most recent item on how to solve the problem. The new information is that there is a repository for not to compile the driver. here is the link http://ubuntuforums.org/showthread.php?t=1515562 As soon as I get time I will try to use it and I'll write the result

Ok, the kernel patch works well, I have used it in Mypaint an inkscape! (gimp actually has a bug)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.