Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Is it possible to open applications in a terminal and have them load on particular workspace? To be clear, what I mean is as follows:

Let's say I would like to open up banshee, I run the banshee command from the terminal. That alone would have it load in the terminal's same workspace. Let's say I run the terminal in workspace 1 (fyi, I use 4 workspaces) but I would like banshee to load in workspace 4. Is it possible to do this from the terminal?

Regards, Ederico.

share|improve this question
    
I'd like to draw attention to this question once again, since it is unanswered. –  Ederico Nov 24 '11 at 17:14
    
I'd like to draw attention to this question once again, since it is unanswered. –  Ederico Dec 17 '11 at 15:23
add comment

1 Answer

You may want to look at a tool called Devil's Pie (look for "devilspie" in software center, or apt-get install devilspie). The description is:

This tool will find windows as they are created and perform actions
 on them, such as resizing, moving to another workspace, or pinning
 them to all workspaces.

You may also want to install gdevilspie, a friendly configuration frontend, as devilspie configuration is done through a possibly arcane text file.

Many window managers have the functionality you need, but as far as I can recall, neither Compiz nor Metacity can do this, and it's a design choice for them, as window arrangement and placement based on actual window properties should not be part of the window manager itself.

share|improve this answer
    
I have tried this out, unfortunately it does not seem to work. I've did this (using the Terminal as an application). I set the window_class and application_name to the Terminal and then I ticked the boxes for the maximize_vertically, maximize_horizontally, center and set_workspace actions. I set the set_workspace value to 2 so that it opens on workspace 2. The maximize settings worked (I guess the center thus becomes redundant) but the application opens in whatever workspace is active rather than in workspace 2. Any idea what could be the problem? In a comment hereunder I'll post the raw text. –  Ederico Jan 2 '12 at 13:22
    
( if ( begin ( is ( window_class ) "Terminale" ) ( is ( application_name ) "Terminale" ) ) ( begin ( set_workspace 2 ) ( maximize_vertically ) ( maximize_horizontally ) ( center ) ( println "match" ) ) ) –  Ederico Jan 2 '12 at 13:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.