Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have 64-but Ubuntu 11.10. The sound works fine, but the keyboard sound keys don't work. The sound icon on the top panel also doesn't work. Also no hardware devices & Running applications are shown in the Sound settings.

Screenshot 1:

enter image description here

Screenshot 2:

enter image description here

Results of some commands that might help:

$ lspci -v | grep -A7 -i "audio"
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
        Subsystem: Dell Device 02be
    Flags: bus master, fast devsel, latency 0, IRQ 46
    Memory at fc500000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: HDA Intel
    Kernel modules: snd-hda-intel

--
01:00.1 Audio device: ATI Technologies Inc RV710/730
    Subsystem: Dell Device 02be
    Flags: bus master, fast devsel, latency 0, IRQ 47
    Memory at fc010000 (32-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: HDA Intel
    Kernel modules: snd-hda-intel

$ cat /proc/asound/cards
 0 [Intel          ]: HDA-Intel - HDA Intel
                      HDA Intel at 0xfc500000 irq 46
 1 [HDMI           ]: HDA-Intel - HDA ATI HDMI
                      HDA ATI HDMI at 0xfc010000 irq 47

I think some packages are missing. Any suggestions ?

share|improve this question
    
Haven't found the solution yet. But for the time being, I'm using Alsamixer to control the volume. –  Paras Dec 14 '11 at 9:53

2 Answers 2

up vote 0 down vote accepted

Here is what i tried... 1. rm -rvf ~/.pulse/

Reboot

No success

  1. https://help.ubuntu.com/community/SoundTroubleshootingProcedure

Run this command sudo apt-get update;sudo apt-get dist-upgrade; sudo apt-get install linux-sound-base alsa-base alsa-utils gdm ubuntu-desktop linux-image-uname -r libasound2; sudo apt-get -y --reinstall install linux-sound-base alsa-base alsa-utils gdm ubuntu-desktop linux-image-uname -r libasound2; killall pulseaudio; rm -r ~/.pulse*; sudo usermod -aG cat /etc/group | grep -e '^pulse:' -e '^audio:' -e '^pulse-access:' -e '^pulse-rt:' -e '^video:' | awk -F: '{print $1}' | tr '\n' ',' | sed 's:,$::g' whoami

as I was having 11.10

Reboot

Guess what.. it worked like ever before :)

Kamal

share|improve this answer
    
Solved the problem. Thank you @Kamal :) –  Paras Dec 24 '11 at 17:55

I've got also the same problem with my sound card. But there's no sound at all. System is 32bit Ubuntu 11.04 with gnome-shell 3.3.2.

$ lspci -v | grep -A7 -i "audio"
Audio device: nVidia Corporation MCP55 High Definition Audio (rev a2)
    Subsystem: Micro-Star International Co., Ltd. Device 7250
    Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 20
    Memory at fbef0000 (32-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: HDA Intel
    Kernel modules: snd-hda-intel

$ cat /proc/asound/cards 
 0 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xfbef0000 irq 20

After type $ sudo alsa reload device shows up in Sound settings, but theres still no sound.

share|improve this answer
    
Read Kamal's solution. It works. For Ubuntu 11.04 follow the link that he has posted. –  Paras Dec 24 '11 at 17:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.