Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have ubuntu 11.10 64 bit:

Linux 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:56:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

I have installed 4 Gb of RAM:

$ sudo dmidecode --type 17 | grep -E "Size|Form Factor|Memory Device|Type"
Memory Device
    Size: 1024 MB
    Form Factor: DIMM
    Type: DDR2
    Type Detail: Synchronous
Memory Device
    Size: 1024 MB
    Form Factor: DIMM
    Type: DDR2
    Type Detail: Synchronous
Memory Device
    Size: 1024 MB
    Form Factor: DIMM
    Type: DDR2
    Type Detail: Synchronous
Memory Device
    Size: 1024 MB
    Form Factor: DIMM
    Type: DDR2
    Type Detail: Synchronous

But my PC can see only 3.2 Gb of it.

$ free
             total       used       free     shared    buffers     cached
Mem:       3347240    1404628    1942612          0      47156     603992
-/+ buffers/cache:     753480    2593760
Swap:      2093052          0    2093052

I found this article: https://help.ubuntu.com/community/EnablingPAE. It says that PAE is enabled by default on 64-bit operating systems, so my system should see my 4Gb RAM. But it doesn't.

What could be the problem?

This duplicate question contains even more detail.

share|improve this question
    
Are you using an onboard graphics adapter which might be taking some of the system memory as graphics memory, perhaps? –  Caesium Nov 19 '11 at 14:06
    
Nope, i have NVidia video card. –  stee1rat Nov 19 '11 at 14:10

1 Answer 1

After chatting with stee1rat, it turned out that his Dell inspiron 530 was using an old (v1.0.3) BIOS, which had a wrong memory map, which causes the BIOS to only recognize 3.2GB of the installed 4GB of RAM. The memory map was supposedly fixed in v1.0.12 and newer of the BIOS, which can be found at Dell's FTP site (look for 530_10xx.EXE, where xx defines v1.0.xx).

Direct link

Unfortunately, despite our best efforts, it appears that using the .EXE to update the BIOS from within FreeDOS is not possible. The only option appears to be to try install the BIOS from within Microsoft Windows.

share|improve this answer
    
Alike issue here, but my bios can recognize 4 gigs (running 32bit and ubuntu can see only 2.9 gigs). So that's not completely true. –  Denys S. Dec 27 '11 at 20:03
    
This is a bit old now, so I'm assuming stee1rat has either figured out a solution or given up (or bought a new computer etc.), but I ran into the same problem, I make here a note of the solution that worked for me. One can run a minimal Windows XP off of a USB drive. This can be made with PE Builder (nu2.nu/pebuilder) or, better yet, if you can find "Windows XP Live USB Edition 2008 2.02", it's even easier. Just follow the instructions for installation of that on a USB, add the BIOS .EXE (I used 1.0.16 because I read some complaints about 1.0.18) to the USB, boot up and run the.exe –  emacsomancer Oct 2 '12 at 2:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.