Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My TV supports 100/120hz output. I tried the following commands to add the mode:

find the magic numbers:

$ cvt 1920 1080 100
# 1920x1080 99.90 Hz (CVT) hsync: 114.58 kHz; pclk: 302.50 MHz
Modeline "1920x1080_100.00"  302.50  1920 2072 2280 2640  1080 1083 1088 1147 -hsync +vsync

Add the new mode:

$ xrandr --newmode "1920x1080_100" 302.50  1920 2072 2280 2640  1080 1083 1088 1147 -hsync +vsync

have a look at xrandr to check the mode is created correctly:

1920x1080_100 (0xec)  302.5MHz
h: width  1920 start 2072 end 2280 total 2640 skew    0 clock  114.6KHz
v: height 1080 start 1083 end 1088 total 1147           clock   99.9Hz

Now to the good part, add the mode to my HDMI output:

$ xrandr --addmode DFP2 1920x1080_100
X Error of failed request:  BadMatch (invalid parameter attributes)
Major opcode of failed request:  157 (RANDR)
Minor opcode of failed request:  18 (RRAddOutputMode)
Serial number of failed request:  32
Current serial number in output stream:  33

I did the same for 120Hz, same issue. Is there anyone who can help me with this?

share|improve this question
    
Did you find a solution for this? –  Stratosgear Feb 24 '12 at 19:57
    
nope can't get it to work. maybe I'm trying something that can't be done? –  Jelle Smedts Feb 26 '12 at 20:48

1 Answer 1

This

$ xrandr --addmode DFP2 1920x1080_100

should be:

$ xrandr --addmode DFP2 1920x1080_100.00

cheers

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.