Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was using the 2.6 kernels with no problems, but when I updated to the 3.0 kernel, my bootup failed. I can manually boot with ctrl+alt+f1 > startx and my login, but admittedly, i googled this and have no idea what I'm really doing. I have been trying to figure out how to go back to the old version, and eventually figured out the grub menu--i booted from all three 2.6 (.8, .10, and .11) editions of the previous version of ubuntu but they all had the same error as the 3.0 kernal.

I can get logged in manually once the boot fails, but when i get to my desktop, wireless is not responsive and will not connect, and portable hard drives do not mount and/or are unresponsive.

the previous version worked perfectly.

I use an asus netbook. it's an eee pc. i don't have two OSs on it. i had to go to another computer to get to the forum...

If the solution is simple, i just don't know what it is.

share|improve this question
    
Ok.. so what did you do? you upgraded or what? –  Uri Herrera Nov 19 '11 at 7:30

1 Answer 1

There is no major difference between "2.6 kernels" and 3.0. It's just a number. Talking about 2.6 is not a good idea, since that implies every major version of Linux since 2003. For instance, the difference between 2.6.38 and 2.6.39 is just as significant as the difference between 2.6.39 and 3.0. Actually, Linux 3.0 would have been called 2.6.40 if only Linus Torvalds could count that high. It makes more sense to talk about "Linux .39" than "Linux 2.6", because the latter means nothing. You can read more about that here: http://www.pcmag.com/article2/0,2817,2388926,00.asp

Now, onto your question. You say that you can't boot, but if you can press ctrl+alt+f1 and run startx, then you have already booted the operating system. The fact that your desktop appears when you run startx, tells me that the problem is most likely your display manager. Ubuntu has switched from GDM to LightDM. You may want to replace it. In order to do that, you first install GDM, then open a terminal (or a console in your case) and run sudo dpkg-reconfigure gdm. Reboot. If it works, then it is a bug in lightdm, which you'll hopefully report on http://www.Launchpad.net.

Please open a different question for your networking issues. This site works best with one question and many answers.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.