Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I saw there are similar questions, but I don't think they answer exactly my questions.

Did anyone managed to get 3D acceleration work under VMWare workstation 8? I have VMware 8.01 installed on Ubuntu 11.10. The guest I am trying is also Ubuntu 11.10.

I manually installed vmware-tools and it went well, except the X-config part was skipped as it said the distribution driver is used. The guest runs well but it seems fall back to 2D mode.

Does any one has any idea how to enable 3D acceleration under VMWare workstaion with Linux guest?

share|improve this question

5 Answers 5

VMWare workstation 8 currently does not support 3D acceleration.

share|improve this answer

According to VMware Workstation 8 documentation (Configuring Virtual Machine Hardware Settings » Configuring Display Settings) 3D acceleration is only available for Windows XP, Windows Vista, and Windows 7 guests.

share|improve this answer

I'm really sorry about the ambiguous answers that you get from these threads. I figured that you have 3D acceleration checked. It still goes back into fall-back mode, even if you update the kernel.

Install the kernel headers, then install VMware Tools. And restart Gnome 3 in terminal, If it still goes into fall-back mode.

This method does work in virtual box with the extensions in the same order above. I just think that it is strange that VMware is supposed to be more powerful than virtural box, but it will not run Gnome 3. I see some instabilities in VMware. There is definitely some 3D graphics issues. When running Mac OS 10.7.3, launch pad flickers when sliding the pages to apps, so does the dock a bit. Gnome 3 seems very sensitive to 3D lag. Hopefully Gnome 3.4 is not so demanding for graphical resources.

share|improve this answer

3D acceleration for Linux guests is only available beginning with VMware Workstation 9.

share|improve this answer

It does. Go to your vhost settings and find the display entry. There is a checkbox to enable 3d acceleration

share|improve this answer
    
I knew there was the checkbox. But it did not work. I would like to know how you get it worked. For example how do you get gnome 3 shell in fedora 16 worked. –  Yan Zhou Dec 31 '11 at 1:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.