Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The checkboxes that appear to be changeable under the Edit / Software Sources dialog box cannot be changed. I click on them and they just turn gray and stay at their current setting.


When I run software-center from a terminal window and try to change one of the checkbox settings, I get:

Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/softwareproperties/gtk/",
        line 649, in on_isv_source_toggled
  File "/usr/lib/python2.7/dist-packages/dbus/", line 143, in __call__
  File "/usr/lib/python2.7/dist-packages/dbus/", line 630, in call_blocking
    message, timeout)

These things happen instead of it properly prompting me for a password (for root privs).

share|improve this question

I can reproduce this if my /etc/apt/sources.list has bad permissions, ie read-only.

what does

ls -l /etc/apt/sources.list


It should look like:

-rw-r--r-- 1 root root 3881 2011-11-18 16:30 /etc/apt/sources.list

You can fix it with

sudo chmod 644 /etc/apt/sources.list
share|improve this answer
That was a good tip. I think that the Software Center is not executing as root and cannot modify this file. It also does not ask me to validate. – Michael Goldshteyn Nov 18 '11 at 16:36
It shouldn't run as root, that's right. But it should ask for your password to elevate it's privileges when it needs to. Not sure why that might not be happening, the only thing I can think to suggest is run "software-center" in a Terminal rather than from the menu and see if there's any revealing errors printed. – Caesium Nov 18 '11 at 16:48
When I run it in a terminal, I get: – Michael Goldshteyn Nov 18 '11 at 17:33
Ok, that looks a bit more involved than a file permissions issue, I'll have to bow out to someone who knows more about DBus – Caesium Nov 18 '11 at 18:36
up vote 1 down vote accepted

The solution was to install: polkit-kde-1

After this and a reboot, the problem was solved.

share|improve this answer
Good to know, thanks for updating this :) – Caesium Nov 22 '11 at 0:34

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.