Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I need to install nodejs-dev package. But sudo apt-get install nodejs-dev throws

The following packages have unmet dependencies:
 nodejs-dev : Depends: nodejs (= 0.4.9-1ubuntu3) but 0.4.12-1chl1~natty1 is to be installed
E: Unable to correct problems, you have held broken packages.

So... What can I do about this error? I run Ubuntu 11.10

share|improve this question

1 Answer 1

up vote 1 down vote accepted

You have a PPA or have added a source that provides 0.4.12-1chl1~natty1, which is for 11.04. You need to remove that PPA, do an update, and then try to install nodejs-dev again.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.