Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

I have a HP MINI 210-1010NR and just installed Ubuntu 11.04 and I can't get my wireless to work. I have checked through multiple Q&A's throughout this FAQ and tried them all. When I go over the wireless thing at the top it says "Wireless Networks device not ready (firmware missing)."

Okay, now here is my

lspci -vvnn | grep 14e4

02:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g 
LP-PHY [14e4:4315] (rev 01)

Also, when I try to open additional drivers it says that "Downloading package indexes failed, please check your network status." I have no means of other Internet Access.

I tried to do the ndisgtk things and attempted to install all of the things that were in the photo but I don't know where to find them.

share|improve this question

marked as duplicate by Rafał Cieślak, hhlp, vasa1, con-f-use, Chris Wilson Mar 24 '13 at 11:35

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Make sure you have a wired connection when opening the Additional Drivers. – mikewhatever Nov 18 '11 at 9:12

You need to have internet for jockey to install wireless driver so make sure you have wired internet first.

If You want to go manual route try:

sudo apt-get install bcmwl-kernel-source

And see if your wireless works or not else try:

sudo apt-get purge bcmwl-kernel-source && sudo apt-get install firmware-b43-installer

If the first process doesnot work.

share|improve this answer
This is what worked for me: sudo apt-get install firmware-b43-lpphy-installer – Robert Corvus Feb 14 '12 at 5:01
First one worked for me. – JohnRos Apr 26 '13 at 20:02

I have the same problem with same driver. This is what I do to install the correct drivers.

1st, install Synaptic Package Manager from the USC, Ubuntu Software Center. It has always been default in Ubuntu until 11.10, but it still works great. Open Synaptic and search for B43. This is what you will get.

Synaptic - B43

Notice the choices available and the drivers I downloaded. If you have a question you can click on the item and a brief description will pop up. It works on my dv5000 series, I just did a fresh install last night. Good Luck!

share|improve this answer

Try ndiswrapper (you most likely have to install it, so sudo apt-get install ndisgtk). This program allows you to use windows drivers for wifi under linux so you have to just download appropriate driver from here and use it with ndiswrapper (it has a gui which you can start by ndisgtk in terminal). The interface is quite simple, there should be no problems with that.

share|improve this answer

There's no need for ndiswrapper and Windows drivers, because the Linux driver already exists,

  • if you see no broadcom wireless device name, uninstall driver, restart computer, install driver and restart again until "firmware missing" message appears with wifi device name under wireless icon after clicking on it (gnome).
  • If you haven't it, you must install a synaptic package manager from Ubuntu software center
  • search "bcm" inside synaptic package manager
  • mark for installation "b43-fwcutter", "firmware-b43-installer", "firmware-b43legacy-installer" and apply, no restart needed. Your Wi-Fi led turns on immediately.


share|improve this answer
git clone git://

cd linux-firmware

sudo cp -a brcm /lib/firmware

sudo modprobe -r brcm80211 && sudo modprobe brcm80211

profit (:

share|improve this answer

This solution encompasses many of the other suggestions you have received so far.

Try connecting to a wired connection (preferably do this somewhere with a wired connection (for the downloads) and a wireless network (to test the drivers)), and following the instructions in this wiki of the Ubuntu Community Documentation. Thus old, this document is still usable.

I have that same network card and both the STA and the B43 drivers work for me. Good luck!

share|improve this answer

Atom Netbook 110 ~ Windows7:Wubi: Ubuntu 12.04

Wireless trouble out-of-the-box

After several Trouble shootings,


USC: Synaptic Package installer

-Opened Package Installer>search "b43" -Installed 3 packages: firmware-b43-lpphy-installer b43-fwcutter firmware-b43legacy-installer



share|improve this answer

In fact the firmware-b43-lpphy-installer and/or b43-fwcutter is all you need.

firmware-b43-installer and firmware-b43legacy-installer do not even install properly on 4312 hardware.

The STA driver (aka bcmwl) may work but not always, so I recommend firmware-b43-lpphy-installer.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.