Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm confused,how can I change the sound output in LXDE? There's not even a single option anywhere unlike other environments.

I've tried doing anything with alsamixerbut still nothing, the output device is the HDMI audio of a Radeon HD card.

Edit: As it Turns out i was able to change the ouput device, but i had to use Gnome for that and its Gnome Sound applet, that is log out and log in once in Gnome change the device, log out and log back in LXDE.

Now the question becomes Why can't i do this in LXDE?

share|improve this question
add comment

4 Answers

up vote 21 down vote accepted

xfce4-mixer

Lubuntu shares many components with XFCE. My suggestion would be to use the XFCE4-Mixer. This still gives you a lightweight solution compatible with the lxde ethos.

enter image description here

to install

sudo apt-get install xfce4-mixer gstreamer0.10-alsa

This installs the following limited number of xfce packages -

exo-utils libgarcon-1-0 libgarcon-common libwnck-common libwnck22 libxres1
  xfce4-mixer xfce4-panel

to run

type xfce4-mixer in a lxterminal

In Options Auto-Mute Mode

It should be set as Disabled.

xfce - Auto Mute Option

pavucontrol

Slightly more heavyweight - you could install pulseaudio and thus use the pulseaudio packages such as pavucontrol

enter image description here

to install

sudo apt-get install pulseaudio pavucontrol

This installs the following pulseaudio packages:

gstreamer0.10-pulseaudio libasound2-plugins libspeexdsp1
  pulseaudio-esound-compat pulseaudio-module-x11 pulseaudio-utils rtkit

to run

type pavucontrol in a lxterminal

share|improve this answer
    
Didn't knew that but do i have to install all of XFCE to have it? –  Uri Herrera Nov 18 '11 at 18:58
2  
it only installs a limited number of extra packages - see the edit of my answer. –  fossfreedom Nov 18 '11 at 19:02
    
Thank you very much :D :D –  Uri Herrera Nov 18 '11 at 19:05
    
... alternatively - if you also want to use pulseaudio you can use pavucontrol ... do you want me to update the answer to say how to do this? –  fossfreedom Nov 18 '11 at 19:08
3  
done.... have fun! –  fossfreedom Nov 18 '11 at 19:24
show 1 more comment

First of all, try lspci and lsusb to check if the device you need is seen by the system.

Secondly in alsamixer try pressing F6, which will let you choose the sound card (I really don't know if this is needed tbh).

And another tip for alsamixer: it doesn't show all parameters when u start it, some are hidden on the right so you just have to go to the right to see them all, I believe there is an output chooser. And also in alsa see if you are viewing the needed items (F5 will show all parameters available).

Hope this helps.

share|improve this answer
    
Yes the device is listed in lspci as alsamixer detects it, selecting the output device only brings a S/PDIF entry but nothing can be done except Mute and unmute. –  Uri Herrera Nov 18 '11 at 9:09
1  
Well this might be also drivers problem, the fact of device being listed in lspci does not mean it has the needed firmware. But , unfortunately I don't know how to check this. –  foxy Nov 18 '11 at 9:19
    
Nope drivers work fine, it's just LXDE that can't change the output device or doesn't have any options for it, see my edit. –  Uri Herrera Nov 18 '11 at 17:15
    
Thanks for the "F6" tip! Volume control for my USB speakers now work :) –  nano Mar 7 at 22:02
add comment

This is what i did to fix the no audio issue in my ASUS laptop:

sudo apt-get install xfce4-mixer gstreamer0.10-alsa

This installs the following limited number of xfce packages:

exo-utils libgarcon-1-0 libgarcon-common libwnck-common libwnck22 libxres1 xfce4-mixer xfce4-panel

To run, type xfce4-mixer in a lxterminal.

In Options:

Auto-Mute Mode : Disabled (changed enabled to disabled)

share|improve this answer
add comment

I am using Ubuntu 12.04 64bits and I recently installed Xcfe-4 Desktop. When I first logged in xfce-4 I noticed there was no sound at all (Rythmbox, games, etc). And I found no icon anywhere to adjust the sound.

This is how I did to fix the problem :

1) Go to the applications menu > Sound & Video > Mixer.

2) In the Sound Card option menu, select Playback: Built-in Audio Analog Stereo (PulseAudio Mixer).

3) The playback window may be empty. Click on "Select Controls..." , enable/check Master then close.

4) Unmute the sound icon just under the volume bar.

I guess you need to check whether you are using PulseAudio or Alsa drivers. This should not change the fact you need to uncheck mute icon in your "Playback: Audio stereo" in Mixer.

I hope this can help :-)

PS : I am a newbie in linux stuff, so please correct me if I said something wrong.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.