Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I keep getting this error dialog with an Unable to mount error E_FAIL ( 0x80004005 ) when I try to mount Guest Additions:

enter image description here

I tried the Force Unmount, but that just closes the dialog with no action taken. If I then reattempt to mount Guest Additions, I just get this same dialog box again. Any help would be greatly appreciated!

share|improve this question

8 Answers 8

up vote 19 down vote accepted

Finally, I figured it out. Here is how you get arount this. First, load Disk Utility and manually eject the disk in the CDROM, by clicking on the Eject button, after selecting the CDROM device. Then try to remount Guest Additions using the key combination Host + D and voila, Guest Additions should mount successfully.

share|improve this answer
1  
Just a quick note, I tried this today and was unable to eject the media. I had to go down a little further on the page and select "Unmount Volume", and then I was able to Eject. –  Chris Sobolewski Oct 14 '13 at 23:37
    
I believe disk utility is a GUI application, yes? How can I achieve what you accomplished here through the command line? –  jeff fabiny 2 days ago

I could not get the autorun to work, installed manually by doing:

cd /media/VBOXADDITIONS_4.2.4_81684/
sudo sh VBoxLinuxAdditions.run
share|improve this answer
    
thanks! this worked nicely and all from cmdline. Only path to additions may vary, for me it was - 'cd /media/kerim/VBOXADDITIONS_4.2.10_84104/' –  kerim Apr 3 '13 at 10:12
    
I had to perform a mixture of this step and Michael Goldshteyn's steps: 1) sudo palimpsest for complete access to device and eject. 2) remount disk 3) sudo sh /media/VBOXADDITIONS_4.3.6_91406/VBoxLinuxAdditions.run did the trick. –  Screenack Dec 21 '13 at 14:42

I had to add one more step.

  1. Unmount Volume
  2. Eject
  3. Rerun Install Guest Additions
share|improve this answer

Unmounting the volume on devices -> CD -> Remove disk from virutal drive

This will show the "Remove disk from Virtual drive" option as disabled on the same page once you clicked.

Then Press Host (Keyboard:Right Ctrl) + D i.e Host+D

This started working installing automatically on my Ubuntu screen.

share|improve this answer

I ran into this error under this scenario.

  1. Turned on Fedora 18
  2. Opened Terminal, Logged in as root
  3. Attempted to install Guest Additions. It failed with a package missing error
  4. Installed the package and rebooted the system
  5. Logged in as guest user and attempted to run Guest Addition, as I was thinking logging in root is not necessary

No matter how many tries I did, I kept on running into VERR_PEM_MEDIA_LOCKED error.

Trying to install by logging into root made this error go away.

So, it seems the OS somehow remembers the user you tried to run the Guest Additions first time, and in successive runs, if you are not logged as that user, it complains.

share|improve this answer

Here is what I followed and it worked. Nothing else. Mine is Ubuntu 14.04 Trusty...

1) Once in Ubuntu, Go to the files folder.

2) On the left side, you will see some options among which there will be "My Computer" and above it "The virtual drive (Named as your ISO file)"

3) Right click on it and select eject.

4) Go back to the "VIRTUALBOX" and go to devices option and select Install Guest Addition CD Image.

5) Hopefully, you wont get the same error.

6) Follow on accordingly. Select "Run". Verify your Password.

7) Let the terminal run and once asked, press enter.

8) Reboot your Virtualbox and this time you will notice the full resolution version.

share|improve this answer

Alternative Workaround for Such an issue

"If all else fails"

I just climb through the network anty copy it to the drive. Mount it as loop.

share|improve this answer

I came across this today and it seems it could not be fixed via GUI operations. So I did it via command line. It worked like a charm!

  1. Devices -> Install Guest Additions...(it's like insert a cd to cdrom)
  2. Open a terminal to login the guest machine
  3. Type below

    sudo mkdir --p /media/cdrom
    sudo mount -t auto /dev/cdrom media/cdrom/
    cd /media/cdrom/
    sudo sh VBoxLinuxAdditions.run
    
  4. You now can do full screen, shared folder, clipboard sharing, etc

share|improve this answer
    
How did you activate the full-screen etc. After doing that still doesn't show them. –  Karl Morrison Oct 27 at 12:58
    
By restart the virtualbox one more time, it will work. At least for my case –  Ace Oct 27 at 17:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.