Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hi I've spent hours trying all the suggestions listed on Forums on this problem all over the Internet and I still can't get my wireless working. It's very discouraging because it might force me to go back to Windows which I hate. Can someone help?

Perhaps I can give you some information to help identify what the issue is? b43 isn't coming up in my list of drivers...just Broadcom STA which doesn't work.

I think I've removed all the blacklisted stuff.

share|improve this question
    
Did you find any suggestions to install drivers from source? Sometimes using the source fixes it. –  RolandiXor Nov 18 '11 at 4:26
    
thanks for your reply! I don't know if I know how to do that. I've installed the b43 several times from terminal: –  Annie Nov 18 '11 at 5:50
    
1 sudo apt-get install firmware-b43-installer –  Annie Nov 18 '11 at 5:50
    
This page has been very useful but I still haven't got the b43 working: linuxwireless.org/en/users/Drivers/b43 –  Annie Nov 18 '11 at 5:51

2 Answers 2

I had the same problem here! This is the fix that I used to great success:

Ubuntu 11.10 getting wireless BCM4311 working

The basics are this:

sudo apt-get update
sudo apt-get install firmware-b43-installer
sudo apt-get remove bcmwl-kernel-source
sudo reboot

The article will give you more background on the issue.

share|improve this answer
    
I used a similar method to fix a friend's wireless before but could not remember the steps. I can confirm also that this works. –  RolandiXor Nov 18 '11 at 5:07
    
I finally got it to work! There were some blacklists on the bcm43xx in some hidden files that I think were responsible...but I'm not really sure. But it's finally working. Many thanks to you both for your help! –  Annie Nov 18 '11 at 6:13
    
@Annie you can mark his answer as answering your question by clicking the tick next to it (gives him 15 rep as thanks, and 2 rep to you for accepting the answer :D) so that others will know this worked and that your answer is solved. –  RolandiXor Nov 18 '11 at 16:31
    
Just thought I'd let you know: I spent hours trying to get wireless working on my parents' machine. Finally, I found this post, and it solved my problem. Thanks! –  Scott Severance Jan 12 '12 at 4:25

There is also a community documentation on Broadcom BCM43xx PCI based wireless network card for Ubuntu 10.04 & onwards.

https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx#Installing_STA_drivers

There are methods for installing the drivers even without the Internet access.

If you don't have Ubuntu CD/USB, download four latest packages (dkms, patch, fakeroot, bcmwl) from

http://archive.ubuntu.com/ubuntu/..

../pool/main/d/dkms

../pool/main/p/patch

../pool/main/f/fakeroot

../pool/restricted/b/bcmwl

Put the .deb files together in a folder, and install by typing this command in Terminal

sudo dpkg -i *.deb

Sorry about my bad English.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.