Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded from 11.04 to 11.10. My machine now hangs during the shutdown process, but can reboot just fine. If I turn off quiet and splash boot options, then the following error is displayed:

Connection refusedId did not get the system bus. Make sure the message bus daemon is running! Message: Failed to connect to socket /var/run/debus/system[fail]o

That is, the [fail] overwrites part of the error message. I am then dropped to a root shell. Running shutdown now causes the same thing to happen. Running reboot from here still succeeds.

Here's what I've tried so far:

  • Setting apci=off has no affect
  • Following the directions from this post gave FATAL: Module rt2860sta not found.
  • Following the directions from this post had no result, but stopped me from running reboot after being put in single-user mode; now when I do this, I get an error saying /run/lock was not mounted, a message saying the system is going to restart, and then it hangs. I can still reboot from within Ubuntu as before.

Any ideas on how to proceed?

share|improve this question

2 Answers 2

Try go to the terminal and write this:

sudo halt

Enter your password when prompted and press enter, and then it should shut down.

share|improve this answer
    
That works better -- the system halts, but it doesn't automatically power off. –  Seth Nov 19 '11 at 3:43
    
You could also sudo reboot and then use the switch... But both are very poor ways of substituting shutdown. –  Costis Aivalis Jan 3 '12 at 9:34

I solved this problem by changing from 64bit to 32bit Ubuntu 11.10.

I tried all of the other ideas. I tried to work on the ACPI issues, I got rid of ModemManager, I tried all combinations of halt, etc. No dice. So I thought if a 64bit driver was messing up the shutdown, maybe a switch back to 32bit would work.

You can do an install from live disk where Ubuntu chooses to install the distro you want while retaining your documents and many of your installed programs. I did have to reinstall System Profiler, all of the DVD decrypt libraries, etc but that was not really too bad (I have a fast FIOS internet).

So for me the solution was to use 11.10 32bit. This will not be okay if you need the 64bit version. Good luck.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.