Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The web browser I use is Firefox (currently in version 8 in Oneiric). According the Compatibility Check information the Moonlight extension is not compatible with FF8. Anyway, I enabled this extension using the AddOn Compatibility Reporter. And, actually, I cannot watch Silverlight streams in an acceptable way: the video gets stuck, the HD keeps buffering (I guess), so I have to close the window.

Does anybody know if there is a way to fix this or a suitable alternative? I'm looking for something which is fully supported and mantained.

share|improve this question

4 Answers 4

up vote 9 down vote accepted
+50

enter image description here

To those that wish to install Moonlight on any Firefox version greater than v4 and like me could not get the Official Firefox Compatibility checker to allow installation...then you can do the following:

  • Download the plugin according to your architecture - 32bit or 64bit
  • Save the .xpi file into an empty folder.
  • Change the file extension to zip if necessary
  • Right-click the .xpi file and choose Extract
  • In the extracted files, open the file install.rdf into your favourite text editor

enter image description here

  • find the area in the file shown - change the maxVersion from 4.0.* to 99.0.* and save (N.B. picture shows 9 - this value needs to higher than your Firefox version)
  • Delete the folder META-INF
  • Highlight all the files - Right click and choose Compress - save the compressed file in Zip format enter image description here
  • Rename the file to have a .xpi extension rather than a .zip file extension
  • In firefox you can use the Firefox Addon wrench symbol to install the modified addon - you will be warned about its authenticity which you can ignore. This warning appears because you deleted the authenticity checks folder META-INF previously. enter image description here

Finally - when Firefox version changes, Firefox will automatically disable the add-on. Use the official Compatibility Reporter to re-enable this modified add-on


A few possible reasons why you have playback issues:

  • The stream you are using doesnt have smooth streaming capability
  • the bitrate is too high for you broadband
  • you are using an underpowered CPU or are RAM starved
  • you graphics card is underpowered
  • You are using open-source drivers which (depending on the graphics card) sometimes can be much slower in terms of frame-rate than their proprietary cousins (ATI/NVIDIA).
  • Compiz issues - sometimes switching to Gnome-Classic (no effects) works better for me.

If you have trouble with a "play" button on-screen during playback and/or "autoplay" in general; goto about:config and set "media.autoplay.enabled" to "false".


Final note - from wikipedia, moonlight development has stopped. The developers have been laid off from Novell and the company that has taken over has stopped (for some unknown reason) the nightly builds. Looks like this technology is in dire straights :(

share|improve this answer

I presume you have installed Moonlight from the official website (as it is not packaged in Oneiric's official repositories). The default download is the Moonlight 4 Preview, since the latest stable release (Moonlight 2.4.1) does not support much of the Silverlight content currently on the web. But Moonlight 4 is not finished and does not currently support Firefox 8.

Unfortunately, as of the time of this writing, the download server for the Moonlight 4 nightly builds (which are even less stable, but which contain the latest features) is currently down. My guess is that current nightly builds would not support Firefox 8 either, though.

Since the latest versions of the Chromium browser are supported, for now I recommend using Chromium when you need to view/play Silverlight content. You can get Chromium by installing the package called chromium-browser (you can do this in the Software Center or by running the command sudo apt-get update; sudo apt-get install chromium-browser in the Terminal). Then, in Chromium, you can download the Moonlight plugin here. Unfortunately the Moonlight website does not properly detect your architecture in Chromium, so it will always suggest the 32-bit version of the plugin; if you have the 64-bit version of Ubuntu, then you should click the radio button for the 64-bit version of the plugin.

Select the architecture, then download the plugin.

(If you're not sure if you have the 32-bit or 64-bit version of Ubuntu, press Ctrl+Alt+T to open a Terminal window, type/paste in uname -m and press Enter. If you see x86_64 then you have the 64-bit version of Ubuntu. If you see i386, i586, i686, or ia32, then you are running the 32-bit version of Ubuntu.)

When you click on the download link (which says Linux/i586 or Linux/x86_64), you will be warned that installing plugins for Chromium could harm your computer. Since you're downloading a reasonably stable version of the plugin and you're getting it from Novell's official download site, you can go ahead and click Continue to proceed in downloading and installing the plugin.

"Extensions, apps, and themes can harm your computer. Are you sure you want to continue?" Click Continue to proceed in downloading and installing the plugin.

Then the plugin should download and automatically install, and immediately start working; you should not even need to restart Chromium. However, if you had a previous version of the plugin installed, you might need to restart Chromium. And if you had pages that were trying to display Silverlight content already open, you will probably have to reload those pages to enable the content to display.

Once you've installed Moonlight, you might want to configure it. To do that, right-click on any Silverlight content (on any page) and click Moonlight Settings. This brings up the Novell Moonlight Configuration window.

Novell Moonlight Configuration window

Some Silverlight content requires that the Microsoft Media Pack be installed. You can install this from the Playback tab of the Novell Moonlight Configuration window.

Like Firefox and other browsers, Chromium has a private browsing mode called Incognito. If you use this mode, you should be aware that 3rd-party extensions (including Moonlight) are disabled by default, because their behavior with respect to your privacy cannot be ascertained.

Incognito - extensions disabled message

If you decide you want to enable Moonlight in Incognito mode, you can do so the Extensions tab of the Chromium preferences. Click the karat triangle to the left of the entry for Moonlight and then check the box labeled Allow in Incognito.

Chromium preferences for extensions

Please note that Moonlight will only be disabled by default for Incognito mode. For normal browsing, it will be enabled by default.

Since many users prefer to use Firefox and newer versions of Firefox are now widely adopted, hopefully Moonlight will support them soon. Until then, you can work around the problem by using Chromium to view sites with Silverlight content, as described above.

share|improve this answer

You have 2 main choices:

  • You can skip the check for compatibility editing the configuration as shown in this tutorial.

  • You can install this plugin that allows the installation of a plugins that otherwise are not compatible.

share|improve this answer

Eliah's post regarding installing Moonlight in the Chromium browser worked for me. I am using Linux Mint 13 (Maya) which is based on Ubuntu.

I also managed to install Moonlight in Firefox using the plugin as the previous commentator suggested. I also installed the codecs it comes with. Moonlight seems to load correctly but there is no sound. Let me know if there is a way to fix this.

Chromium is a good short term fix but not a good solution. It takes my CPU to the limit, overheating my old laptop. Unfortunately, according to Wikipedia, "In December 2011 Miguel de Icaza announced that work on Moonlight had stopped with no future plans."

So our only hope is that HTML5 will eventually solve the problems with the plugins.

Thanks for your help!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.