Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to get rid of the Hibernate and Suspend options on the top-right menu in Unity. These do not work on my netbook and having them close to "logout" is not useful.

share|improve this question

1 Answer 1

I assume you're using a much earlier distro since this post is apparently from 5 months ago. Anyway, I just did the opposite of what you're doing yesterday on Precise. Run the following command to open the file to edit:

sudo gedit /var/lib/polkit-1/localauthority/10-vendor.d/com.ubuntu.desktop.pkla

Scroll to the bottom. Check to see if the following information exists, and if not add them:

[Disable hibernate]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=no

[Disable suspend]
Identity=unix-user:*
Action=org.freedesktop.upower.suspend
ResultActive=no

Doing this makes those options do nothing when you click them; they will disappear from the menu after you restart your computer.

share|improve this answer
    
Does not work in 13.10 –  Takkat Mar 30 at 11:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.