Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to attach remote FTP directory as a local directory in my system. I will use curlftpfs line in the fstab file , but to login I have to pass my user name and password. The user name has a special character (@) and it needs to be escaped via octal ascii code. The octal ascii for '@' is 100. But when I try to enter the following into the FSTAB file,

curlftpfs#myself\100myself.com:ftpPassword@ftp://ftp.mysite.com /mnt/somedir 

I get an error saying

Error connecting to ftp: Couldn't resolve host 'myself.com:ftpPassword@ftp://ftp.mysite.com'

The fstab does not recognize escaped symbol @ (\100) and thinks that the FTP site should start immediately after the @ symbol (just like I haven't escaped it).

Can someone help? Why I cannot escape @, when it can be done for space character, for example?

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

It seems that this is not possible in fstab file as @ symbol is also a trigger. Experts recommend using SSHFS instead (https://help.ubuntu.com/community/SSHFS).

I will mark this as an answer.

share|improve this answer
add comment

you can do this another way... for example

I just added ,credentials=/home/martijn/.smbpass to my fstab's list of options for the mount in question and in the /home/martijn/.smbpass file I have the following:

username=martijn
password=P@ssword

the password works that way.

Hope this helps someone.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.