Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is what I get when I try to install Banshee:

sudo apt-get install banshee
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 banshee : Depends: libdbus-glib1.0-cil (>= 0.5) but it is not installable
           Depends: libdbus1.0-cil (>= 0.7) but it is not installable
           Recommends: banshee-extension-soundmenu (= 2.3.1+git20111114.r1.aea7412-0ubuntu1+maverick) but it is not going to be installed
E: Broken packages

I tried to search for "how to fix broken packages" posts, but none of them helped. What do I do to fix this?

share|improve this question
    
Are you using some PPAs? What happens when you open a terminal and type sudo apt-get -f install? –  Bruno Pereira Nov 17 '11 at 14:04
add comment

2 Answers

up vote 1 down vote accepted

You've installed the banshee 2.3.1 ppa for ubuntu maverick meerkat? Info you probably should have included in your question, rather than let the detectives figure it out :)

= 2.3.1+git20111114.r1.aea7412-0ubuntu1+maverick

The simplest way of dealing it would be to remove the offending repository from your '/etc/apt/sources.list.d'. Then, add the following ppa

sudo add-apt-repository ppa:banshee-team/ppa

After you've done that,

sudo apt-get update && sudo apt-get install libdbus-glib1.0-cil libdbus1.0-cil 

(they're available on the aforementioned ppa). Then, you can re-add the daily ppa,

sudo add-apt-repository ppa:banshee-team/banshee-daily;sudo apt-get update && sudo apt-get upgrade

and you can install the soundmenu extension from there.

ps. I don't know if removing the unstable ppa is strictly necessary -- you'll probably get away with just adding the stable ppa and installing the libdbus* dependencies from that.

share|improve this answer
    
Thanks a lot! Had no idea the daily repository could conflict with the stable one. –  EpsilonVector Nov 17 '11 at 14:46
add comment

Try this:

sudo dpkg --configure -a
sudo apt-get update
sudo apt-get install banshee

Still the same problem afterdoing that? Download the missing dependencies from packages.ubuntu.com, install them, and try again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.