Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On ubuntu 11.10 using gnome classic I accidently made an error and now I have to deal with a redirect button to the gnome tweak tool in the top bar of the gnome interface, right next to the locations button.(but can be moved accros the top bar) I don't want and can't delete the button. Is there a solution to get rid of it?

share|improve this question
add comment

3 Answers 3

To remove this icon, alt+right-click on the icon and click remove in the menu.

share|improve this answer
2  
Do you have any idea what the rationale behind not showing the remove option in response to a normal right click? This is the most absurdly user unfriendly 'feature' I've seen in awhile. How the heck are you supposed to discover it without Google? –  Joseph Garvin Sep 27 '12 at 2:43
    
@JosephGarvin I have not been able to figure it out. –  RolandiXor Sep 27 '12 at 6:20
    
@JosephGarvin My understanding is that if you don't hold down the Alt key, mouse input on a panel applet is interpreted by the applet itself. Holding down Alt makes the panel interpret the input. So, for example, if you had an applet that showed a special applet-specific menu on right-click, you'd right-click without Alt to show that menu, but you'd right-click with Alt to show the generic menu that shows options like removing the applet altogether. –  Eliah Kagan Oct 1 '12 at 19:58
1  
Never-the-less I've made this mistake a few times - seems like it's a UI feature designed by a technically minded person rather than someone who has humans in mind –  Rehno Lindeque Nov 6 '12 at 18:02
2  
That's very unintuitive. –  imwilsonxu Feb 19 '13 at 10:04
add comment

Now it's Windows+Alt+rightclick (a.k.a. Super+Alt+rightclick) as described here. In a few years, it'll be shift+ctrl+super+alt+numlock+middleclick.

share|improve this answer
1  
Haha +1 for being right and funny :) –  RolandiXor Feb 19 '13 at 16:06
add comment

Actually it's compiz that add the Windows key to the Alt+Rightclick combination. You can test this by killing it. Compiz needs Alt+Rightclick for something else apparently.

Gnome classic session: Windows+Alt+Rightclick

Gnome classic session, no effects: Alt+Rightclick

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.