Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The following used to work:

gsettings set com.canonical.Unity.Devices devices-option "Never"

But after I reinstalled yesterday the devices-option key is gone and so it fails. dconf-editor only shows that the key is not there, but doesn't allow me to create one.

share|improve this question
add comment

2 Answers 2

The setting is available via the CompizConfig Settings Manager. If you install the compizconfig-settings-manager package and run ccsm (or find it in the launcher), the "Experimental" tab of the "Ubuntu Unity Plugin" module gives you the options of "Always", "Only Mounted", and "Never".

share|improve this answer
    
Thank you, that worked so far, those 'normal' partitions and devices are gone from the launcher. But two (encrypted) device mapper partitions still show up as question marks. So I leave this open for now, would be nice to get rid of them too. (sry for my poor english:) –  Mei Nov 17 '11 at 23:26
add comment

as far as internal partitions (drives), it's an option - the default has been changed to 'OnlyMounted' If this is what you are referring to it can be changed in dconf-editor or gsettings in a limited fashion ~$

gsettings range com.canonical.Unity.Devices devices-option
enum
'Never'
'OnlyMounted'
'Always'

gsettings set com.canonical.Unity.Devices devices-option Always
share|improve this answer
    
Thanks, but my problem is that I have no key 'devices-option', that's what 'gesettings range...' is telling me too. And I don't know how to recreate it (or why it's gone, I reinstalled and updated yesterday) –  Mei Nov 17 '11 at 9:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.