Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 11.10 Desktop on my Windows 7 Laptop (Lenovo B570).

Wired connection works fine, but I'm not able to even switch wireless on.

As soon as I click the wireless button from off to on, it goes back to off automatically.

Tried looking online for answers, not able to find anything.

Any help is appreciated, thank you!

share|improve this question
    
Please post the output of sudo lshw -C network. Just to know, when you say "I clicked it form off to on", do you mean marked the checkbox next to "Enable Wireless" in the "connection inidcator"? –  DeoxNa Nov 17 '11 at 5:12
    
What is the output from: iwconfig? –  david6 Dec 2 '11 at 20:53
add comment

2 Answers

add blacklist acer_wmi to your /etc/modprobe.d/blacklist.conf , for example:

sudo -s
echo "blacklist acer_wmi" >> /etc/modprobe.d/blacklist.conf

and restart your computer.

share|improve this answer
add comment

I have the same laptop (b570) and had a difficult time. Hopefully you have dual boot with windows. In my case I had to blacklist acer-wmi in the document "/etc/modprobe.d/blacklist.conf" (at the bottom type in "blacklist acer-wmi" without quotes) then reboot back into windows and turn on the wireless, reboot back into Ubuntu and it worked.

I had tried for days with just blacklisting, then messing with the hardware switch on the actual case, tried the fn key and most everything I could google with no luck. Then upon needing wireless booted into windows realized it was off there too, turned it on, back into Ubuntu 11.10 and fixed.

share|improve this answer
add comment

protected by Community Apr 28 '12 at 22:42

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.