Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using GNOME 3.2 and my problem is that while working on terminal my prompt is usually at the bottom of screen. As GNOME notifications keep popping up on new mail, chat or song change, it becomes hard to work at the lowest line of terminal.

Is there any way I can set prompt location few lines above the last line in the Terminal, so that I don't have to run clear every time?

share|improve this question
add comment

2 Answers

Rather than attempt to prevent some number of lines near the bottom of the Terminal window from being used, you might want to instead simply resize the Terminal window to whatever best serves your needs. You can put your mouse pointer over the lower-right corner of the Terminal window (or, really, over anywhere on the lower edge) until the mouse pointer changes to a different icon representing resizing. Then click and hold, and drag the border upwards until the window is however small you want it.

To make it so that all Terminals will be of a custom height (and, if you like, width) when you start them, go to Edit > Profile Preferences in Terminal. A window with the title Editing Profile "Default" will come up (or it will give a different profile name, if you're using a named custom profile). In the General tab (which should already be showing), check the box labeled Use custom default terminal size. Then you can decrease the number of rows from 24 to whatever you like.

If your Terminal window is maximized, so that it takes up the whole screen and cannot be resized, then you should restore it to normal size (using the buttons on the window decorator, i.e., on the bar at the top of the window). Then you can either move it to a different location on the screen so that it is more convenient, or resize it as described above.

share|improve this answer
    
@ Eliah Kagan: You are right in a way. But for that I have to resize it everytime I use my terminal. Also it is difficult to concentrate when you are working in the last line of window. –  Atul Kakrana Nov 17 '11 at 0:20
    
@AtulKakrana Good point about how you'd have to manually resize each time if you were following my instructions; I just edited my post to explain how to change the default Terminal size. As for your second point, that probably means that the answer I've proposed will not be suitable for you (though you might try changing your desktop wallpaper or background color to something less distracting, I understand that may not be adequate for your needs). Hopefully someone else will know how to do what you are asking (then you can accept their answer). And if I find out how, I'll edit my post again. –  Eliah Kagan Nov 17 '11 at 1:35
    
@Elian: Thanks for taking time and writing down detailed instructions about resizing terminal. I actually know all those options. But the problem is that I use smaller size (set in terminal preferences) when I work on multiple things and full size when only working on terminal. There must be some way to configure prompt location. If I find any answer I post it here. –  Atul Kakrana Nov 17 '11 at 2:48
1  
@AtulKakrana You might have better luck searching for information about this if phrase the problem in different terms. Presumably, what you want really has nothing to do with the bash prompt at all. My understanding is that what you really want to do is to make the Terminal start scrolling down when text is written to some row higher than the final row. –  Eliah Kagan Nov 17 '11 at 2:55
    
@Elian: You nailed it right will file a new post –  Atul Kakrana Nov 17 '11 at 3:22
show 1 more comment

You could try using guake, at least as a work-around. It has an option, "Main Window Height" which allows you to vertically adjust how much screen is utilized. This way you can prevent the prompt from ever being under your notifications. The option stays saved, you won't need to resize everytime.

Guake has some cool features, like a single button hotkey

  • Install guake via the terminal with sudo apt-get install guake
  • Then type guake-prefs to bring up the preferences dialogue.
  • Find the "Main Window Height" scrollbar at the bottom of the menu and adjust to suit your needs.

enter image description here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.