Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 10.10 and I have two users registered on it. Once User1 enters to the system and doesn't close his session and User2 enters to the system, User2 can't see Network Manager in his panel. So, he can not see list of available WiFi, etc.

How can I solve this bug?

share|improve this question

2 Answers 2

up vote 6 down vote accepted

This is a well known upstream bug that appears to be unfixable. It has been open for over two years. You can see the bug report here.

In the event that you are logged in second and you therefore do not have the nm-applet in your panel, you can run the following command to kill the currently running instance and then restart network manager for your login

sudo killall -9 nm-applet && nm-applet &
share|improve this answer
    
Is there any way to automate this in a shell script + setuid upon user switching? (I'd like users with no administrative permissions to have nm-applet as well..) –  dr Hannibal Lecter Nov 27 '10 at 22:43
    
dr Hannibal Lecter: You probably could do something along these lines. I would suggest posting a new question, either here on on unix.stackexchange.com. You'll get better feedback than asking just me. –  Richard Holloway Nov 29 '10 at 13:56

Normally this means the second user isn't authorized to change NM settings.

  • Make common connections available system-wide.
  • Give the second user the authorizations required from the Users configuration screen.
share|improve this answer
    
What happens if I want to turn off the wifi? –  Bakhtiyor Oct 18 '10 at 13:12
    
@Bakhtiyor see my second point. –  badp Oct 18 '10 at 13:48
    
What authorizations are you talking about? Because I gave the authentication for connecting to wireless networks from the User Configuration. –  Bakhtiyor Oct 18 '10 at 16:17
1  
@Bakhtiyor that ought to be sufficient... –  badp Oct 18 '10 at 16:21
    
But it is not sufficient. I still have the same problem. –  Bakhtiyor Oct 21 '10 at 16:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.