Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having trouble with my netbook. Ubuntu works fine otherwise except it won't recognize my HDMI port. I've tried Ironhide and Bumblebee project, and these do enable hardware acceleration, but not the HDMI output. If I search the net all the answers deal with audio over HDMI, but I'd be happy to get even video at 1080p.

As a sidenote, the VGA output works but it's not acceptable since my home TV doesn't support HD resolutions over VGA. This is why it must be HDMI.

Ideas, suggestions, logs/configs you need?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

It is because the HDMI output is connected to the NVIDIA card, and Bumblebee can't handle those type of connection (because of virtualgl if I'm right), which is why you can't either use Flash into a browser with the nvidia, because the npviewer.bin plugin is not launched with optirun.

I'm having the same problem with the HDMI (I also have an Asus 1215N), it is the only reason why I keep using Windows instead of Ubuntu (or another distribution).

You just have to wait for a solution, and I don't think Bumblebee/Ironhide is one for this problem..

PS : If I remember right, some people report that a earlier version of Bumblebee made it work when booting Ubuntu, showing the Ubuntu SplasScreen and then dissapear with when entering into the Login part.

Sorry for that :S

Just one question, nothing to do with you question, Is Ubuntu fast for you? and if Yes, which version of Ubuntu and wath Desktop (gnome3, unity-3d, unity-2d..).

share|improve this answer
    
I thought that might be the reason why it doesn't work, too bad. And yeah, it's as fast as I can expect with this hardware, running with the defaults (unity-3d) on 11.10. –  onik Nov 16 '11 at 21:56

I have a Asus U30 (with Optimus) and HDMI works fine. I think it won't detect HDMI, but you can try Jupiter applet (click in applet -> Video Displays -> Enable Both).

BTW, in my system, i can only connect HDMI after setting both displays (if i connect HDMI and then enable both displays, i got a kernel panic :)).

Hope it helps.

share|improve this answer
    
@onik if you try this applet, could you please post here the results for the 1215N? (I am not using Ubuntu right now, the same reason I asked you about the speed in Ubuntu, since I find Ubuntu extremely slow). Thanks in advance –  aliasbody Nov 16 '11 at 22:42
    
Tried it quickly, but couldn't get it to run. Will try again after work. –  onik Nov 17 '11 at 6:43
    
Can't get Jupiter to show up at all even after whitelisting all apps, and caused random slowdowns, had to uninstall. –  onik Nov 18 '11 at 7:14
    
@onik, dont you have option "Powersave" enabled? That makes system save the most energy it can. The option "High performance" should be the default powersave plan (probably the best name to this mode would be "balanced"). What do you mean saying you cant make it show up? It doesn't starts? –  Salem Nov 18 '11 at 12:12
    
@Salem Exactly, it doesn't open any windows or show an icon in the status bar (or notification area, or whatever it's called). –  onik Nov 18 '11 at 14:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.