Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using the Transmission which was shipped in 11.10. All the configurations in Ubuntu 11.10 are the same as they are in my Mac OS.

In Ubuntu, Transmission is not downloading at all: 0 peers at all times.

When booting into Mac OS, all seeds turned out to be fine (high speeds, lots of seeders).

share|improve this question
Me too, randomly, but if I leave it for some time, it catches the train. So if you weren't patient, try it, and if not I don't know what is the issue. Some suggest changing Encryption in privacy options, especially if it's set on 'require encryption' and tweaking Privacy tab in general. I don't have references right now, but quick Google can lead to those I guess – zetah Feb 2 '12 at 6:28
Running "sudo ufw allow out 6969/tcp" may fix problem. – Ringtail Feb 17 '12 at 18:26
up vote 4 down vote accepted

In the Transmission menu go to EditPreferencesNetwork.

Check if your port (usually 51414 by default) is open, if not go forward by units (51415,51416..) until you find an opened one, this should work.

Be sure to disable your firewall for transmission (if you have set one).

share|improve this answer
I'd add to it that maybe you should enable the Network->UPnP option. – lujbilami Mar 12 '12 at 15:03

As I previously recommended Ktorrent I feel I should report on that.

Lately I was not satisfied with Ktorrent anymore (although I would prefer it to Transmission any day) because it seemed still rather heavy and even speed seemed too low (or maybe other settings need adjusting ? - I only adjusted the upload speed and nothing else).

So, I tried qBittorrent and I recommend it, for the speed and also because it is lighter than Ktorrent. (Or at least gives that impression. Looking at the task manager, they are not very different, but I find qBittorrent more responsive and better adjusted - it looks like utorrent - while Ktorrent, while being a decent program has odd features like that you cannot close the program from the taskbar icon, it has tabs that seem useless and that you cannot close - well, in fact there's a close button to the right, it took me one month to see it, and so on.)

sudo add-apt-repository ppa:hydr0g3n/ppa
sudo apt-get update
sudo apt-get install qbittorrent

Then, I tried Flush, which is lighter, while still having a lot of features and looking basically the same. It surely deserves a try.

sudo add-apt-repository ppa:konishchevdmitry/flush
sudo apt-get update
sudo apt-get install flush

When having issues with a torrent client it is advisable to use multiple ones to test them.

Considering the clients with more features and settings, Deluge is one of the most used, reliable and with a lot of support (I mean wiki, faqs etc). Another one that is very interesting is Tixati (here). It has A LOT of features for advanced users. (Don't worry, colors are customizable too :-))

share|improve this answer
I would say that this doesn't directly address the user's problem, since 1. If there are problems with routing or the firewal the problem is likely to also apply to other torrent applications, 2. Transmission is OK, since it has a non-bloated interface, full-fledged feature set and a large user base. 3. The user's question addresses Transmission. – lujbilami Mar 12 '12 at 15:10

Here are some possible answers for your question:

From the transmission forums : From ubuntuforums :

share|improve this answer
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Marco Ceppi Feb 4 '12 at 21:09

You can also instal Deluge Bit torrent client. I think it is in the software centrum. You can also find it here: Deluge is very similar with Utorrent. If this is not working too for you there must be an onthe reason why.

share|improve this answer

I gave up Transmission when confronted with a similar issue, immediately tried Deluge and found it too heavy for what I was trying to find: something very lightweight like utorrent - so I checked Ktorrent, which seemed lighter.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.