Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded to 10.04, then to an ATI graphics card (I used the internal graphics port before) and now noticed that blender is behaving very strange. Menus don't work or very slowly, fragments on the screen and so on. I didn't try anything else because it's impossible to use.

The card is an ATI Radeon HD 4650.

Did anyone experience similar problems ?

share|improve this question

closed as off topic by fossfreedom May 22 '12 at 19:15

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Are you using the vesa, ati or the free driver? –  Bobby Oct 17 '10 at 20:34
    
If you are experiencing these problems then you might want to consider creating a bug report. It could be a real problem and I am sure that the devs would like to know. –  Robert Massaioli Oct 17 '10 at 21:30
    
This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions on filing a bug report are here. –  fossfreedom May 22 '12 at 19:15

5 Answers 5

I have an ATI Radeon HD 4350 with the open source drivers, and Blender seems to work fine on Ubuntu 10.10 (with visual effects enabled).

You could try a 10.10 live CD to see if the problem still exists there for you.

Another thing you can test, on your 10.04 install, is to disable the "visual effects" in the Appearance configuration dialog. Sometimes these effects interfere with applications that also use OpenGL.

share|improve this answer

I have an ATI Radeon 4850 and I use a logitech trackball mouse. My OS is Ubuntu 10.04. I tried starting blender using this command from a terminal:

LIBGL_ALWAYS_SOFTWARE=1 blender

That made things somewhat better, but did not really fix the problem. Disabling visual effects in the appearance settings fixed everything (after i restarted blender without the LIBGL... setting).

I would have just voted up the above answer, but I don't have enough points yet, and this was a very frustrating problem for me so I wanted to say something. Thank you JanC, your answer helped me out.

share|improve this answer

Two things I would suggest: Use the fglrx driver if you are using the open-source driver, Try using Blender 2.5, as this is much better than older versions, and should be so as well with the cases where 2.4x was troublesome (it was known to be on ATI cards).

share|improve this answer

Could You show the display of Yoyr xorg.conf.new file? (HowToCreate Xorg file)

One more thing - did You chck if 3D rendering works?

glxinfo | grep -i direct

(might bee required to install mesa utils)

share|improve this answer

I think that's it's somthing that i problem with the Blender that you have install and it need to be restart that the problem can be solve but if that doesn't work you can always test to see if the OS is slow itself if not i think it's the program.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.