Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I try to run a game under dosbox, but it has no sound, and in the terminal dosbox says:

MIXER:Can't open audio: No available audio device , running in nosound mode.
ALSA:Can't subscribe to MIDI port (65:0) nor (17:0)
MIDI:Opened device:none

Update

I changed the ports to 128:0 in the dosbox config file and now it says

ALSA:Client initialised [128:0]
MIDI:Opened device:alsa

but still no sound :(

share|improve this question
add comment

3 Answers 3

up vote 3 down vote accepted

Turns out the sounds of the game were muted from the game's own options menu. Changing the MIDI port to 128:0 was still needed though, to enable dosbox's sound.

share|improve this answer
    
Why not accept your own answer? ;) –  z7sg Mar 31 '12 at 11:45
    
I had forgotten this question, thanks for reminding me. Probably was because of the rule that you can't select your own answer before 1-2 days have passed, and in the meantime I forgot about the question! –  sashoalm Mar 31 '12 at 12:07
add comment

The following solution found on the net is somewhat old but since the problem is the same it might still be valid.

Quote:

You need to tell SDL (which is what DOSBox is built on) to use PulseAudio, type export SDL_AUDIODRIVER=pulse in a console window, then start dosbox from the same window by typing dosbox.

Source: http://www.herikstad.net/2009/04/dosbox-and-ubuntu-904-jaunty.html

share|improve this answer
add comment

Solution to the sound problem: if you still have problems getting the sound to work on dosbox 0.74 or any other version, first of all do the things the comments above states, and do them from scratch, I mean everything from directory to installation. And last CHANGE THE SOUND IN GAME FROM DOSBOX, usually theres a "setsound,exe" file or similar, access it:

c mount /home/yourname/yourdosfolder
c:
cd yourgame
yourgame
setsound.exe

(ALWAYS START DOSBOX FROM TERMINAL)

Listen folks, I recently installed Ubuntu 11.04, hence first time ever using Linux, after a week of crashes and bugs, and so on, I finally got it working fine, and I'm loving it, it was all worthwhile for the cause - open source. And now It's all exlusive on my laptop, but man I tell you it was difficult installing and running ubuntu as the only OS, I do not recommend such attempts, but if you have several pc's around then by all mean D

share|improve this answer
1  
This does not really answer the question as it stands. It would be more useful if you include the steps from the comments as they should be carried out. –  RolandiXor Sep 25 '12 at 19:22
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.