Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The Software upto date Option automatically download the upgarde for GIMP. but While installing its giving me the error. how to upgrade the same


Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  gimp
Suggested packages:
  gimp-help-en gimp-help libgimp-perl gimp-gap gimp-console
The following packages will be upgraded:
  gimp
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/4,388 kB of archives.
After this operation, 324 kB disk space will be freed.
Do you want to continue [Y/n]? Y
(Reading database ... 151157 files and directories currently installed.)
Preparing to replace gimp 2.6.11-2ubuntu4 (using .../gimp_2.7.4-2011102201~oo_amd64.deb) ...
Unpacking replacement gimp ...
dpkg: error processing /var/cache/apt/archives/gimp_2.7.4-2011102201~oo_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/gimp/2.0/plug-ins/file-xmc', which is also in package gimp-plugin-registry 3.5.4-1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/gimp_2.7.4-2011102201~oo_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

share|improve this question

3 Answers 3

If you are using a custom PPA for Gimp remove it.

Remove package gimp-plugin-registry and gimp

sudo apt-get remove gimp-plugin-registry gimp

Fix packages

sudo apt-get -f

Update Gimp package

sudo apt-get update && sudo apt-get upgrade
sudo apt-get install gimp gimp-plugin-registry

Install gimp-plugin-registry and gimp

sudo apt-get install gimp-plugin-registry gimp
share|improve this answer
    
--------------------------------- I tried to remove the package , but it seems all is interdependent I am Getting Following Error Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: gimp : Depends: libgimp2.0 (<= 2.6.11-z) but 2.7.4-2011102201~oo is to be installed Depends: gimp-data (<= 2.6.11-z) but 2.7.4-2011102201~oo is to be installed E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution). –  Manish Varia Nov 16 '11 at 19:12
    
on running apt-get -f install I m again getting the same Error. –  Manish Varia Nov 16 '11 at 19:14
    
Have any gimp PPA's active at the moment? –  Bruno Pereira Nov 16 '11 at 19:24
    
nope.. I had just installed it day before yesterday..!! today restarted my machine & then Software up-to-date told that updates are available install those so i just installed.. –  Manish Varia Nov 16 '11 at 19:29
    
try to remove both packages, update and fix them and then try to install. –  Bruno Pereira Nov 16 '11 at 19:41

The gimp contains the file /usr/lib/gimp/2.0/plug-ins/file-xmc that is already installed by the package gimp-plugin-registry. AS a file can only be from one package you can't have both packages installed.

Judging from the version number your gimp package (but not gimp-plugin-registry) is from an unofficial package source. So you should either try find a package of gimp-plugin-registry that works with that gimp package or revert to the official gimp package.

share|improve this answer
    
I tried to remove the package , but it seems all is interdependent I am Getting Following Error Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: gimp : Depends: libgimp2.0 (<= 2.6.11-z) but 2.7.4-2011102201~oo is to be installed Depends: gimp-data (<= 2.6.11-z) but 2.7.4-2011102201~oo is to be installed E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution). on running apt-get -f install -- > Back to square 1 , same error –  Manish Varia Nov 16 '11 at 19:16
dpkg: error processing /var/cache/apt/archives/gimp_2.7.4-2011102201~oo_amd64.deb (--unpack):
trying to overwrite '/usr/lib/gimp/2.0/plug-ins/file-xmc', which is also in package gimp-plugin-registry 3.5.4-1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)

Ok, this is a general answer rather that OP's problem.

This message indicates that some package is trying to overwrite a file that is included in another. The safest solution is to remove one of the two packages. In this example it could be either gimp or gimp-plugin-registry.

This is normally due to adding not so well maintained PPA's, since these problems are fixed by bots in the main repositories.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.