Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On my network i use apt-cacher-ng on server and add Acquire::http { Proxy "http://[]:3142"; }; to /etc/apt/apt.conf on clients.

So apt-get can't download file through proxy with wget.

share|improve this question
Isn't there a flash plugin package containing actual flash in the Partner repository? That would fix half the problem, anyway. – zpletan Nov 16 '11 at 15:47
up vote 3 down vote accepted

apt-cacher-ng shouldn't interfere with the actual package download. The problem with these two packages is they don't actually contain their payload. They are both lightweight packages that contain scripts to download extra data with wget when you install them.

This is simply for legal reasons. The extra files licenses' conflict with the repo's.

If you need to force these downloads through a proxy too, you can, either by setting up wget's proxy settings in /etc/wgetrc:

http_proxy = http://proxy-ip:8080/

Or you can use the longhand command to pass the proxy through to it:

sudo http_proxy=http://proxy-ip:8080 apt-get install flashplugin-installer ttf-mscorefonts-installer


The proxy address I'm talking about in these solutions should not be apt-cache-ng - that's only for caching package downloads. I'm talking about the same proxy that you'd use in your browser, for example.

share|improve this answer
OK it work, but i had scripts using wget to download files on local server and they don't work. The second solution work but my users can't do it. Thank you for the answer ! – Daiko Nov 16 '11 at 16:14
Thanks /etc/wgetrc help me! – gavenkoa Apr 1 '14 at 10:22

I put:

use_proxy = on
no_proxy = 10.*.*.*,localhost
http_proxy =
https_proxy =
proxy_user = XXX
proxy_password = YYY

to /etc/wgetrc for permanent settings.

Seems that


from /etc/apt/apt.conf doesn't used by downloaders...

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.