Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Yesterday I got my first Ubuntu (11.10 32 bit) installation (wish me luck), and I ran into a problem with my USB network card.

I use a wireless USB stick by edimax (it is called IEEE802.11b/g/n nano USB adapter or also EW-7811Un).

My problem is that Ubuntu seems to be able to use the USB to see the networks around me, but when I try to connect to my network - it just keeps trying and failing.

I am connected to the internet through a

300M Wireless N Router Model No. TL-WR841N / TL-WR841ND

I have other computers in the house which are able to connect to the internet. And the same computer previously had Windows on it - and it managed to connect to the internet with no problem.

Can you please advise on how this can be resolved? (what output should I send you?)


share|improve this question
There is a bug report on this issue bugs.launchpad.net/ubuntu/+source/linux/+bug/852190. Have you tried to use ndiswrapper to see if you can get it to work with windows drivers? –  Engels Peralta Nov 16 '11 at 12:59
Hi Engels - great catch. I see at the end of the thread that there is a solution, but it is not clear to me where to download it from. Can you advise? (THANKS for your help!) –  Tal Galili Nov 16 '11 at 13:17
There is a link in comment #36. :~) Not really sure how it works though. The description says "Linux driver for Kernel 2.6.38(and earlier)", and 11.10 has 3.0. –  mikewhatever Nov 16 '11 at 13:46
Tal you can download the drivers from realtek.com.tw/downloads/… and follow this askubuntu.com/questions/68198/… –  Engels Peralta Nov 16 '11 at 14:00
Hi Engels - I just followed the steps on the link you provided - it managed to see the driver correctly, but this didn't fix the problem (e.g: seeing a network - but failing to connect to it). :( Any more suggestion to follow would be great. –  Tal Galili Nov 16 '11 at 21:57

1 Answer 1

up vote 3 down vote accepted

o.k., I solved the problem.

It took a bunch of steps - I have detailed them here:


Thank you Engels for your kind help! (I also gave credit in the post, and will gladly link to whatever website you might want from your name)

share|improve this answer
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  RolandiXor Nov 17 '11 at 12:41
Hi Ronald, The essentials are already answered in the linked question in the comments. I didn't add to the core of the answer, but organized it a bit. You are welcome to edit my answer as you please :) –  Tal Galili Nov 18 '11 at 9:13
In your link there, it says to blacklist the rtl8192cu (or approximate) driver which is the driver I have currently functioning (same model and everything). I had to instead blacklist ath and ath5k. –  Enigma Mar 3 '13 at 6:23
It would be interesting to see how useful this answer will remain if the link becomes unavailable. –  hmayag Jul 5 '14 at 9:56

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.