Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm experiencing problems with Eclipse development on 11.10.

I am developing an Eclipse RCP application. When I launch the app from Eclipse and work with it for a bit gradually the context menus show less options, then disappear completely. At this point the UI of the whole OS hangs, I have to switch to console mode and kill my RCP.

It seems to happen anytime between showing 1 context menu and many (20+). It happens if I run the app in normal or debug mode. It happens if I run with Unity or Unity 2d. It did not happen on my 10.04 install.

Here is what I've tried:

  • Tried running with the Sun JRE and the issue still occurs.
  • Using gnome instead of unity and the issue still occurs.

Has anyone else experienced this / can anyone give me some pointers on where the issue may be?

share|improve this question

closed as off topic by jrg Mar 2 '12 at 17:36

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
I haven't had this problem particularly, but I was experiencing strange Eclipse behavior and the problem was that I was using the OpenJDK. You should try the SDK from SUN, the official one. For me that was the solution. –  bioShark Nov 16 '11 at 11:16
    
Thanks for the suggestion, I was using an IBM JRE, I have tried the official Sun JRE and the problem still occurs. –  katsharp Nov 16 '11 at 11:29
    
@katsharp I'm having almost the same problem (Eclipse randomly hangs on Ubuntu 11.10 64 bits, and freezes the whole Unity UI). Did you ever find a solution? –  Andres F. Jan 25 '12 at 18:44
    
Not really, I went back to using 1004 as it was making me too unproductive. I have been too busy recently to try again. –  katsharp Jan 26 '12 at 9:19
    
This should have been reported as a bug. Vote to close =) –  Ringtail Mar 2 '12 at 16:48

1 Answer 1

What about checking eclipse logs?. I had similar problem with the IDE itself, an attempt to open context-menu in project explorer was freezing the whole Ubuntu 11.10 desktop (albait it seemed to resume in couple of minutes on its own).

Based on eclipse logs the likely source of the problem was a known bug affecting SWT on top of GTK - see https://bugs.eclipse.org/bugs/show_bug.cgi?id=348205. For me it seems that running eclipse on top of JDK 6 instead of JDK 7 is a temporary remedy as the problem has not manifested itself since.

share|improve this answer
    
Thanks, but this isn't the problem –  katsharp Jan 20 '12 at 0:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.