Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Installing Deb packages on the command line, using dpkg -i, only installs the package in question and displays errors of unresolved dependencies (manually solved by apt-geting the packages it complains about). How do I automatically resolve dependencies when installing standalone packages?

share|improve this question

2 Answers 2

up vote 9 down vote accepted

You can use apt-get -f install to install all the packages dpkg -i complains about (but looking at your question you probably knew that ;) ).

gdebi might be a better alternative.

Description: Simple tool to install deb files
gdebi lets you install local deb packages resolving and installing its 
dependencies. apt does the same, but only for remote (http, ftp) located 
packages. 

On a 3rd note... gdebi was replaced by the Ubuntu Software Center. If you install the .deb from within GDM (nautilus) USC will take over and try to install the deb. And that includes the dependencies. That is if you are not bound to command line ;)

share|improve this answer
    
Never thought of apt-get -f install, thanks! Looking for command solutions, quite aware of both gdebi and USC. –  Oxwivi Nov 16 '11 at 9:56
    
Oh wait, gdebi is command line tool. I'm sorry to ask this, but can you remove your answer? It seems this question was a duplicate, and I delete any duplicate question of mine. :) Comment on the question if you do. –  Oxwivi Nov 16 '11 at 9:59

From the 1.1 branch onwards, apt-get supports installing local packages along with dependencies in the way of:

sudo apt-get install your-package.deb
share|improve this answer
    
Unicorn is here and apt-get is still 1.0.9. –  Barafu Albino Oct 27 at 17:19
    
@BarafuAlbino It's in Debian experimental now: packages.debian.org/search?keywords=apt. We might see it in 15.04, perhaps. –  muru Oct 27 at 17:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.