Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have around a 150gb hard drive that I had fully allocated to Ubuntu 10.10. I fired up the gparted live cd and reduced it by 47gb for a small ntfs partition for Windows.

When it was completed, I rebooted and Ubuntu seemed to load up fine, however, I get the following error at the gdm login screen:

The configuration defaults for GNOME Power Manager have not been installed correctly. Please contact your computer administrator.

I also have noticed that it says I am using 103gb of 103gb on my Ubuntu partition. Before the resize, I was using about 40gb of space.

Why does it suddenly think I'm using 103gb?

share|improve this question
    
please attach the output of df command –  silent Oct 17 '10 at 18:10
    
What output do you get from dpkg -C? –  qbi Oct 17 '10 at 18:45
    
df -h: /dev/sda1 103G 102G 0 100% / –  Kristopher Oct 17 '10 at 19:00
    
dpkg -C gives no output –  Kristopher Oct 17 '10 at 19:05

2 Answers 2

up vote 1 down vote accepted

I have had this exact problem before, and believe it or not, the answer is rather simple. If you have a livecd/usb, run a disk check on the disk from the terminal and allow it to fix and problems found, and voila, problem solved.

Just for a heads up, to expand on why this happens: sometimes when you resize the partition, it get's marked as if it is read-only. When this happens, some programs will not function correctly. Once you do a disk check and allow it to fix problems, they drive will remember it's correct state, and you'll be back to smooth sailing. My suggestion for the future is, if you need to resize a disk again in the future, wait until the operation is completed and then always do a disk check immediately after (gparted allows disk checks, but a manual check from the terminal is always best).

share|improve this answer

I just encountered the same problem, with Ubuntu 12.10 installed on 32GB SSD. I was noticing that system began to operate slower recently but did not fully aware before system message "no space on drive.."

I tried to google it but most of the solutions were about the mount issues, which did not apply to me.. Took some time to find the problem, but it seems there was this nonsense xsessions.error file got 23GB (typically places on $HOME folder). when i deleted it, baam!

dummy solution: run disk usage analyzer and find which folders take the space more. Open a file manager and navigate to that folder, look to hidden folders as well, and simply delete the damn file!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.