Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Fresh install of 11.10 x64. I set up XMonad with gnome-session as I did before on 11.04, following the guide on the Arch wiki. Everything works, but there's this weird vertical space about the size of a scrollbar on the side of the screen. The space is also above xmobar (the battery system tray icon is hidden behind it and I can't click it).

XMonad weird space (since I can't post images)

Is there some weird XMonad or Gnome option I'm missing? I don't even know where to begin to look.

share|improve this question
    
shortly after this i got fed up with ubuntu and switched to arch, which just uses a stock gnome 3. clearly, this isn't a solution, but this post deserved an update. i've also switched from trayer to stalonetray, which seems to integrate better with xmobar. –  Andrew Feb 3 '12 at 17:49

2 Answers 2

Something is setting _NET_WM_STRUT_PARTIAL to block that part of the screen. For me it was trayer.

If you're using trayer try using --SetPartialStrut false to see if that fixes it. If not you'll have to track down what is setting it. If you're using trayer on the same edge as xmobar that sets the correct edge as blocked already, so even though technically things could go on top of trayer they won't since xmobar will block that space.

share|improve this answer

I was on the edge at giving up on Ubuntu just like you and I am a returning linux user..so not a total newbie.As always,the most elegant solution is the simplest one.In my case "cvt" generated wrong data,which I just discovered after few days of headaches.

In short,you will have to use "xvidtune" to generate new numbers,which you will have to insert either in your xorg.conf or xrandr command line tool.If inserting in xorg.conf you should have similar line in your Monitor Section:

Modeline "1280x1024_60.00" 108.88 1280 1284 1420 1712 1024 1025 1028 1064 -HSync +Vsync

If using "xrandr" to change resolution you should use something like this:

xrandr --newmode your_choice_of_name 173.00 1920 2048 2248 2576 1080 1083 1088 1120

xrandr --addmode VGA1 your_choice_of_name

xrandr --output VGA1 --mode your_choice_of_name

Of course,changing the numbers with the one from "xvidtune" I just hope I helped somebody,because I spent many hours trying to resolve that problem and couldn't seem to find solution to it. Good luck.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.