Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Under 11.04, my wifi connection was fine and running at full 802.11n speeds. After upgrade, wifi becomes painfully slow. Wired connection operates normally. Ran command lines

echo "#disable ipv6" | sudo tee -a /etc/sysctl.conf
echo "net.ipv6.conf.all.disable_ipv6 = 1" | sudo tee -a /etc/sysctl.conf
echo "net.ipv6.conf.default.disable_ipv6 = 1" | sudo tee -a /etc/sysctl.conf
echo "net.ipv6.conf.lo.disable_ipv6 = 1" | sudo tee -a /etc/sysctl.conf

Then restarted.

No change. After downgrading to 11.04, normal WiFi operation was restored.

share|improve this question

closed as not a real question by Bruno Pereira Mar 17 '12 at 9:18

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Did you try disabling ipv6 in the network's properties (from the GUI) just in case? –  RolandiXor Nov 16 '11 at 4:04
1  
Welcome to Ask Ubuntu! We need more hardware information to help you, can you look at this question and then edit your question adding the information? –  Jorge Castro Nov 16 '11 at 4:23
1  
This question appears to be abandoned and unanswered, could you perhaps add more detail to your question? If you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, then please flag explaining that (as well as editing your question with any details you have). –  jrg Jan 30 '12 at 0:15
add comment

2 Answers 2

I had this issue (fast on 11.04, slow on 11.10). Symptoms were ping times regularly in the several seconds (to ping other local, wired addresses).

I tried {{11n_disable=1}}, disabling ipv6, upgrading the kernel to the latest, all to no avail. The rest of the house (other OSes and various devices) had (more or less) excellent network, as I did before upgrading to 11.10. This was using the {{iwlagn}} modules.

I eventually checked the release notes of the firmware of my router. It appears that it has issues with WEP, which apparently didn't manifest themselves before 11.10...:

If you configure the router in WEP & WPA-PSK type for 130/270Mbps mode, the throughput will be low (around 40 Mbps.) Its recommend to use WPA2-PSK or none security mode to achieve the optimized performance.

I was using WEP (a little lax about security, perhaps), so I switched to WPA2-PSK, and I'm really happy, getting ping times of 2ms again, and transfer rates of up to 80-100Mbit/s when I'm close to my access point, whereas before I would get ping times of several seconds and throughputs measured in single digit kilobytes per second.

share|improve this answer
add comment

Same thing happened to me with my HP dm1z. I had the brcmsmac driver installed (I saw it in "Connection Information" in the WiFi dropdown menu).

I found a workaround on launchpad (I lost the URL because I was searching on my phone, and the browser doesn't retain history).

If you're using bcrmsmac: open /etc/modprobe.d/blacklist.conf and add:

blacklist bcma

blacklist brcmsmac

Make sure the Broadcom driver from "Additional Drivers" is installed and reboot.

If you're not using bcrmsmac, then I have no idea how to help. Good luck!

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.