Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded from 11.04 to 11.10 today. During upgrade, the system freezed when configuring/installing software center. Unfortunately I had to give it cold reboot. After that I am able to log in to new 11.10 but when I try to install anything, I get

E: dpkg was interrupted, you must manually run 'dpkg --configure -a' to correct the problem.

sudo dpkg --configure -a

I run that and again it hangs at configuring software-center. I do not know what to do!

I tried

sudo apt-get remove --purge software-center

But it says since apt-get was interrupted, run dpkg --configure -a (and then the cycle repeats, freeze at software-center).

**

Update 1:

**

I tried the steps as suggested but no success. It freezes when configuring Software-center. Here are my steps:

sony@sony-VGN-CS17G-R:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=11.10
DISTRIB_CODENAME=oneiric
DISTRIB_DESCRIPTION="Ubuntu 11.10"
sony@sony-VGN-CS17G-R:~$ uname -a
Linux sony-VGN-CS17G-R 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:50:42 UTC 2011 i686 i686 i386 GNU/Linux
sony@sony-VGN-CS17G-R:~$ LANG=C;sudo apt-get --simulate --purge autoremove
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  libboost-python1.42.0* libdvbpsi6* libmagick++3* libmatroska3* libphonon4*
  libx264-106* linux-headers-2.6.38-8* linux-headers-2.6.38-8-generic* phonon*
  phonon-backend-gstreamer* python-gtkmozembed* python-pypdf*
  python-pythonmagick* xulrunner-2.0* xulrunner-2.0-mozjs*
0 upgraded, 0 newly installed, 15 to remove and 0 not upgraded.
45 not fully installed or removed.
Purg libboost-python1.42.0 [1.42.0-4ubuntu2]
Purg libdvbpsi6 [0.1.7-1]
Purg python-pythonmagick [0.9.1-3ubuntu6]
Purg libmagick++3 [8:6.6.0.4-3ubuntu1]
Purg libmatroska3 [1.1.0+dfsg-0ubuntu2]
Purg phonon [4:4.7.0really4.5.0-3ubuntu4]
Purg phonon-backend-gstreamer [4:4.7.0really4.5.1-1ubuntu3]
Purg libphonon4 [4:4.7.0really4.5.0-3ubuntu4]
Purg libx264-106 [2:0.106.1741-3]
Purg linux-headers-2.6.38-8-generic [2.6.38-8.42]
Purg linux-headers-2.6.38-8 [2.6.38-8.42]
Purg python-gtkmozembed [2.25.3-7ubuntu2]
Purg python-pypdf [1.13-1]
Purg xulrunner-2.0 [2.0+nobinonly-0ubuntu1]
Purg xulrunner-2.0-mozjs [2.0+nobinonly-0ubuntu1]
Conf language-pack-gnome-en (1:11.10+20111006  [all])
Conf language-pack-gnome-en-base (1:11.10+20111006  [all])
Conf libmono-system4.0-cil (2.10.5-1  [all])
Conf libmono-system-configuration4.0-cil (2.10.5-1  [all])
Conf libmono-posix4.0-cil (2.10.5-1  [all])
Conf libmono-system-core4.0-cil (2.10.5-1  [all])
Conf libdbus1.0-cil (0.7.0-4  [all])
Conf libdbus-glib1.0-cil (0.5.0-3build1  [all])
Conf libglib2.0-cil (2.12.10-2ubuntu1  [i386])
Conf libgconf2.0-cil (2.24.2-1  [all])
Conf libgdata1.7-cil (1.7.0.1-1build1  [all])
Conf libgkeyfile1.0-cil (0.1-2ubuntu2  [all])
Conf libmono-system-drawing4.0-cil (2.10.5-1  [all])
Conf libgtk2.0-cil (2.12.10-2ubuntu1  [i386])
Conf libgtk-sharp-beans-cil (2.14.1-2build2  [all])
Conf libgudev1.0-cil (0.1-2build1  [all])
Conf libmono-sharpzip4.84-cil (2.10.5-1  [all])
Conf libmono-addins0.2-cil (0.6.1-2ubuntu1  [all])
Conf libmono-zeroconf1.0-cil (0.9.0-2build1  [all])
Conf libnotify0.4-cil (0.4.0~r3032-3build1  [all])
Conf banshee (2.2.0-1ubuntu2  [i386])
Conf banshee-extension-soundmenu (2.2.0-1ubuntu2  [i386])
Conf libubuntuone1.0-cil (0.11.0-0ubuntu2  [all])
Conf banshee-extension-ubuntuonemusicstore (2.2.0-1ubuntu2  [i386])
Conf liblaunchpad-integration1.0-cil (0.1.54  [i386])
Conf libmono-addins-gui0.2-cil (0.6.1-2ubuntu1  [all])
Conf libmono-csharp4.0-cil (2.10.5-1  [all])
Conf gbrainy (2.03-1ubuntu1  [all])
Conf libappindicator0.1-cil (0.4.1-0ubuntu2  [all])
Conf libart2.0-cil (2.24.2-1  [all])
Conf libglade2.0-cil (2.12.10-2ubuntu1  [i386])
Conf libgmime2.4-cil (2.4.26-0ubuntu2  [all])
Conf libgnome-vfs2.0-cil (2.24.2-1  [all])
Conf libgnome2.24-cil (2.24.2-1  [i386])
Conf libmono-management4.0-cil (2.10.5-1  [all])
Conf libndesk-dbus1.0-cil (0.6.0-5  [all])
Conf libndesk-dbus-glib1.0-cil (0.4.1-3build1  [all])
Conf libreoffice-l10n-en-gb (1:3.4.3-1ubuntu1  [all])
Conf libreoffice-help-en-gb (1:3.4.3-1ubuntu1  [all])
Conf libreoffice-l10n-en-za (1:3.4.3-1ubuntu1  [all])
Conf mono-csharp-shell (2.10.5-1  [all])
Conf openjdk-6-jre-lib (6b23~pre10-0ubuntu5  [all])
**

> Conf software-center (5.0.1.4  [all])   ---------> Freezes here

**
Conf tomboy (1.8.0-1ubuntu1  [i386])
Conf ubuntu-desktop (1.245  [i386])

I have used the simulate option of apt-get; else I would not be able to copy the terminal. I tried not following these steps and moving on, but eventually , someway or the other system freezes when software-center comes into picture.

share|improve this question
add comment

1 Answer 1

The Package Manager Troubleshooting Procedure both fixes numerous problems (including many problems that produce these symptoms), and produces important information about problems that it is unable to fix. Please follow steps 1-4 of that procedure.

That may well simply solve your problem, but if it doesn't, then please edit your question to add information about how you performed those actions, as well as the complete text from the Terminal (which you can, for example, enclose between <pre> and </pre> tags so that it appears correctly).

share|improve this answer
    
Aah this looks good. Thanks I will try it and edit the question. Currently I am at work so cannot try it out now. I hope this works. Thank you. –  Ian McGrath Nov 16 '11 at 2:59
    
Well, if following those steps fixes the problem, then you needn't edit the question, you can just accept this answer (and upvote, if you wish). If following these steps does not fix the problem, then you should add the information gleaned from doing so to your question, which will likely make it possible for me or someone else to give you an answer that does fix it. –  Eliah Kagan Nov 16 '11 at 3:04
    
Sure, I will do that. I tried to upvote you but I need 15 reputation to do that. I am working on it. –  Ian McGrath Nov 16 '11 at 4:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.