Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just like using emacs on putty. I just transfered to Ubuntu from windows.

I also got error message when I tried to open a matlab .m file using emacs.

Code: emacs job.m

701 $ emacs job.m
Warning: locale not supported by Xlib, locale set to C
Warning: X locale modifiers not supported, using default
Warning: Cannot convert string "-*-courier-medium-r-*-*-*-120-*-*-*-*-iso8859-*" to type FontStruct
Warning: Cannot convert string "-*-helvetica-medium-r-*--*-120-*-*-*-*-iso8859-1" to type FontStruct

Besides, in the IDE of emacs, all the characters are not readable.

Thanks a lot for any help.

share|improve this question

1 Answer 1

To run emacs in the Terminal without a GUI (i.e., without it creating a graphical window for itself), use:

emacs -nw

The -nw flag stands for "no window."

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.