Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've included ppa:mozillateam/firefox-next in my Software Sources, but even though Firefox 9 beta got released, my system still has Firefox 8! Why is this, and how do I get the latest?

share|improve this question

3 Answers 3

press ctrl alt t to open a terminal window and do the following commands.

sudo add-apt-repository ppa:ubuntu-mozilla-daily/ppa

then

sudo apt-get update

sudo apt-get install firefox-trunk

share|improve this answer

The "ppa:mozillateam/firefox-next" should soon have Firefox 9beta1, and hen its ready, you'll be prompted to update.

If you want to, download a beta directly from Mozilla.

Update: Firefox 9b1 has been published in the PPA on November 16.

share|improve this answer
    
-1 Per launchpad.net/~mozillateam/+archive/firefox-next/+packages, firefox 9.0~b1 is currently pending, not published, so people on this PPA will be on firefox 8. See i.imgur.com/7jI1g.png. –  zpletan Nov 16 '11 at 4:15
    
Indeed, I must have looked at lines just below the right ones. –  mikewhatever Nov 16 '11 at 4:24

Sometimes, the guys running the firefox-next PPA run into some problems getting it built, which I think is the case now. You can manually check the status of their builds at https://launchpad.net/~mozillateam/+archive/firefox-next/+packages. Eventually, they'll fix it (they always do), but until then, you could:

  • Keep an older version.
  • Download 9.0b from firefox.com.
  • Add the ubuntu-mozilla-daily ppa.
  • Use some other clever solution that I didn't think of.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.