Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It seems that this problem is specific to Ubuntu and not Gnome 3 itself, that's why I'm not posting it on SuperUser but here.

I installed at least 3 instances of Ubuntu Oneiric Ocelot (11.10) on different hardware lately, all intended to work with gnome-shell (Gnome 3) as default Desktop environment.

On two of these system the default shortcut of Alt+F2 did not work from the beginning. I had to configure it over the System Settings > Keyboard > Shortcuts under System > Show the command prompt to make it work. But on the system where it worked, the shortcut in this window was not visibly configured.

Also I wanted to configure Win+e to open my Home folder with Nautilus and Win+w to open a gnome-terminal. I configured this on the Launchers menu, it then showed Mod4+W and Mod4+E now accordingly. Note that the W and E are upper case, don't know if this is relevant.

The shortcut to open a terminal works in most of the cases, although in some rare cases I can't get it to open the terminal, no matter how often I press the button. This is clearly not the meaning of a global hotkey.

Even worse: The shortcut to open my Home folder almost never works. If I'm in a textbox in Firefox for example, I see the cursor blinking up when pressing, but nothing happens. If the Desktop is on focus, for pressing Win+e I get a little textbox in the lower right showing an e as if selecting a file in Nautilus by simply typing while in focus. But the problem exists also outside of textboxes. In most of the cases it helps to hammer it multiple times but then most of the times multiple instances of Nautilus open up. This is clearly not useful.

What is it with the global hotkeys? Those things did always make problems for me, already in lower versions of Ubuntu and in Gnome 2. Now it seems to be out of control completely. What components are responsible for handling this? What can I do to make this work smoothly all the time and on all installations?

share|improve this question

1 Answer 1

This is an Ubuntu-specific bug. A workaround is to run this command from the terminal to get your keyboard shortcuts working again:

mv ~/.gconf/apps/metacity/global_keybindings ~/.gconf/apps/metacity/global_keybindings-old
share|improve this answer
    
I moved the file and restarted my Gnome session by logging out and back in. Only the Mod4+w hotkey was undefined afterwards, after setting it again, it works. I can't say yet if it works better than before. What comes to mind here, as Mod4+e is not undefined afterwards, that its configured somewhere else for some strange reason. That maybe a hint why it acts so differently. –  aef Nov 15 '11 at 23:52
    
Both the Launchers > Home shortcut and the shortcuts defined under Custom Shortcuts aren't saved inside the XML config in ~/.gconf/apps/metacity/global_keybindings . They both don't work and they are probably managed by something else that is not working properly. Does anyone have an idea what that could be? –  aef Nov 21 '11 at 1:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.