Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have GNOME Shell 3.2.1 installed on Ubuntu 11.10, and I'm trying to install extension on it. I downloaded via apt-get dock and alternative-status-menu, and ofcourse gnome-tweak-tool, but the extensions didn't appear in the tweak tool(after relogin).

So I followed the advice on this answer and changed the versions in the metadata files, and than the extensions appeared in the tweak tool - but the tweak tool was printing many errors, and the extensions were not working - I didn't get the extra shutdown options in the status menu, and I didn't get the dock. I did notice a problem of not being able to click the leftmost area of the scrollbar when the dock extension was activated - like the dock was stealing the mouse pointer from the other applications - but still, no dock.

So, I found this answer and followed it to the letter, and it did get rid of the scheme parsing error, but I'm still getting alot of Gtk-CRITICAL errors when I run the tweak tool - I get 20 times the same error:
(gnome-tweak-tool:3158): Gtk-CRITICAL **: gtk_widget_get_preferred_height_for_width: assertion 'width >= 0' failed
Also, now I can't enable the extensions in the tweak tool(before I edited the files in gtweak I could set them to on - they just didn't work) and I get an orange warning triangle next to them.

So, does anyone know how to solve this?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Update gnome-tweak-tool either from git-master or from the ppa:ricotz/testing PPA. It has just been changed to fix compatibility with gnome-shell master.

share|improve this answer
    
Thanks. Now the teak tool works(had to reinstall the extensions though, since I messed with them manually). –  Idan Arye Nov 21 '11 at 21:14
    
Always a good idea to make a copy before playing :-) glad you got it wking :-) –  bmbaker Nov 27 '11 at 16:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.