Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I would like to have an install with:

  1. Ubuntu Desktop with no additional applications or games
  2. Graphical interface only when I manually run 'startx'

I am using Ubuntu server and would like a GUI, but do not want all of the additional desktop applications and games. (I'm using it with CLI mode.)

share|improve this question
Thanks alot guys , i am new here so i was shocked thats someone changed my ? ...Thanks again thats wt i was asking – One Zero Nov 15 '11 at 19:08
Possible duplicate:… – Christopher Kyle Horton Nov 15 '11 at 19:30
up vote 4 down vote accepted

I did exactly this myself using:

sudo apt-get install ubuntu-desktop --no-install-recommends

Keep in mind that this will give you the bare minimum for a graphical desktop and will probably enable lightdm at startup. You can correct this by setting the kernel to boot to text mode:

  1. Open a terminal and run:

    sudo nano /etc/default/grub
  2. Change the line that reads:



  3. Run:

    sudo update-grub
  4. Restart.

Edit: Hmmm... that doesn't seem to be working. Probably you should just remove the lightdm package.

share|improve this answer
Can you explain how to do that good Mr. Penguin? :P – James Nov 15 '11 at 19:15… (working) – One Zero Nov 15 '11 at 19:23
Thanks i will try it – One Zero Nov 15 '11 at 19:29

See the Server GUI documentation for how to do this. Before installing a GUI on an Ubuntu Server system, please take note of the good reasons given there for not to install or run GUI's on production servers.

On any Ubuntu system with a display manager installed (which provides graphical login), you can disable graphical login (requiring a user to run startx to start X11) using these instructions. However, since GDM is replaced with LightDM in Oneiric (though you can still install and use GDM if you want), you should run sudo service lightdm start instead of sudo service gdm start if you're on Ubuntu 11.10 (or later, as more releases come out).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.