Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a password protected zip file which was created in Windows. When I am trying to extract the same file under Ubuntu I get the error need PK compat. v5.1 (can do v4.6). Any idea how to proceed?

share|improve this question

According to this thread you can use 7z for this. First install p7zip-full package with:

sudo apt-get install p7zip-full

Then either use the GUI or extract the archive with this command:

7z e /path/to/file

or

7z x /path/to/file

(second one preserves directory structure).

share|improve this answer
    
very good that also the GUI (file-roller) understand to use p7zip if installed! – Pisu Feb 6 '15 at 7:56
    
This fixed the problem for me. Note that even though this fixes file-roller, the unzip tool will continue to report this error, so you'll have to use 7z for normal zip/unzip. – Cerin Nov 2 '15 at 16:46

Fix zip file by the use of fixing broken zip file missing parts

Item http://www.fixbrokenzipfile.zipfilefix.com will give you the conception how to handle the issue

share|improve this answer
    
The link is broken... – papukaija Jul 7 '13 at 10:59
    
No, it's not a broken zip file... – Abdillah Dec 23 '15 at 0:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.