Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can mount my remote server home using:

mount servername:/home /mnt/home

but this only lasts until reboot.

I added the following the the end of /etc/fstab:

servername:/home /mnt/home

but I get an error while restarting saying mount failed. I opened the (recovery?) console as suggested by the error message, there I could see the server is not recognized. I also tried pinging its IP but it was unreachable. Perhaps this is because we're using a proxy?

So, what can I do to mount this location permanently?

share|improve this question
    
Is that an NFS share? –  Nick HS Oct 17 '10 at 13:36
    
Please copy-paste all error messages to your question. –  Gilles Oct 17 '10 at 13:38

1 Answer 1

up vote 2 down vote accepted

Entries in /etc/fstab normally have four to six fields; I'm not sure if omitting the third field (filesystem type) and fourth field (options) will work. Try

servername:/home  /mnt/home  nfs  auto

In fact one problem I can foresee is that since the filesystem type is not present, the boot scripts try to mount the filesystem too early. If you explicitly specify a network filesystem, that filesystem is mounted only when the network is up.

share|improve this answer
    
Thanks you Gilles. –  David B Oct 17 '10 at 13:59
    
No field could be left out in fstab, it is just their position that render them meaningful. –  enzotib Oct 17 '10 at 15:15
1  
@enzotib: It's the position from the left that counts, so you can leave out the rightmost few fields. This is commonly done for fields 5 and 6 (which have to do with dumps and fsck order and are only needed for main OS partitions). –  Gilles Oct 17 '10 at 15:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.